Bug 30638 - Sndconfig blows up when trying to detect Opl3 chipset midi.
Sndconfig blows up when trying to detect Opl3 chipset midi.
Status: CLOSED DUPLICATE of bug 26860
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 06:23 EST by Bryn Davies
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 06:23:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn Davies 2001-03-05 06:23:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9smp i686; en-US; 0.8)
Gecko/20010217


 Yo.

 When trying to configure an Opl3 soundcard under Sndconfig, specifically
an ESS1868 PnP, the wave device detection goes fine, but when
trying to load the modules to play the midi sample, the following happens:

 
 The following error occurred running the modprobe program:         
                                                                           
        /lib/modules/2.4.1-0.1.9smp/kernel/drivers/sound/opl3.o:
init_module: No such device
        /lib/modules/2.4.1-0.1.9smp/kernel/drivers/sound/opl3.o: insmod    
        /lib/modules/2.4.1-0.1.9smp/kernel/drivers/sound/opl3.o failed     
        /lib/modules/2.4.1-0.1.9smp/kernel/drivers/sound/opl3.o: insmod
midi failed

 I can insmod the opl3 module by hand with no issues, however, the midi
module is nowhere to be seen.  NB, this card has worked out of the box with
previous versions of RHL back to at least 6.0, and possibly 5.2.

Reproducible: Always
Steps to Reproduce:
1. Install ESS1688 PnP.
2. Run sndconfig.
3. Sob, wail, etc.
4. Don't listen to Mp3's.
	

Actual Results:   The sound modules, soundcore, sb_lib etc remained loaded.
 No dice on the midi though, and the configuration wasn't written out to
/etc/modules.conf.

Expected Results:   I should have heard some horribly distorted midi, and
then the program should have made some changes to my /etc/modules.conf.
Comment 1 Bill Nottingham 2001-03-05 11:01:03 EST

*** This bug has been marked as a duplicate of 26860 ***

Note You need to log in before you can comment on or make changes to this bug.