Bug 26860 - sndconfig sb16 midi fails
sndconfig sb16 midi fails
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
gsimpson@mountaincable.net
Florence Gold
:
: 30638 31570 31921 33143 (view as bug list)
Depends On: 22875
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-09 16:10 EST by Glenn Simpson
Modified: 2014-03-16 22:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 20:03:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glenn Simpson 2001-02-09 16:10:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


Sound Blaster 16, which worked on 7.0, fails for the same configuration on
Fisher.
Using sndconfig indicates the audio works correctly, but MIDI can not be
configured correctly.  This may be related to bug 26789 (AWE64
configuration issue).

Manual config gives the same fault.
opl3.o: init-module: no such device  insmod midi failed

Reproducible: Always
Steps to Reproduce:
1.Install a Sound Blaster 16 in an ISA slot
2.on a text screen (ex: CNTL-ALT-F2) issue sndconfig
3.Ian's voice for audio works normal.  Midi fails.  Manual config is set to
  io=0x220, irq=5, dma=1, dma=5 (I don't think that is used), io=0x330
These parm work on release 7.0
	

Actual Results:  The audio subsystem is not available

Expected Results:  Audio output on sound events and when using Gnome
multimedia, 'try it' should play a sound sample.
Comment 1 Glen Foster 2001-02-09 18:15:40 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Bill Nottingham 2001-02-12 14:25:01 EST

*** This bug has been marked as a duplicate of 22875 ***
Comment 3 Kosta Rojdestvensky 2001-02-25 23:56:03 EST
This bug marked as RESOLVED (under the Fisher),
but it still exist under the Wolverine !
Comment 4 Bill Nottingham 2001-02-26 00:02:31 EST
It's resolved as a duplicate, which it is. Please refer to the bug that it's
a duplicate of for more info.
Comment 5 Joachim Frieben 2001-03-02 03:38:25 EST
It is impossible to query bug 22875. Actual Bugzilla ouput is:

   "Permission denied. Sorry; you do not have the permissions
    necessary to see bug 22875."

This should be fixed. MIDI configuration by means of 'soundconfig'
fails for ESS1869 based Compaq AudioDrive ISA card too.
Comment 6 Bill Nottingham 2001-03-02 12:09:37 EST
Blarg, *someone* decided to reclassify it, after it was *INTENTIONALLY* set
that way. 

Reopening this while I go beat someone here about the head.
Comment 7 Bill Nottingham 2001-03-02 16:51:50 EST
In any case, assigning to kernel. It's still a duplicate of bug 22875, but
as long as that one stays private, we'll leave both open.
Comment 8 Bill Nottingham 2001-03-05 11:00:53 EST
*** Bug 30638 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2001-03-12 17:45:10 EST
*** Bug 31570 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2001-03-15 20:03:25 EST
*** Bug 31921 has been marked as a duplicate of this bug. ***
Comment 11 Bill Nottingham 2001-03-16 17:59:49 EST
This should be worked around in sndconfig-0.64.5-1; although the problem
with the sb driver deactivating the opl3 resources on unload is still
there.
Comment 12 Bill Nottingham 2001-03-25 21:57:52 EST
*** Bug 33143 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.