Description of problem:
xchat-2.8.4-4.fc8.1 doesn't start anymore when only xchat and its dependencies
are updated. But current xchat needs a symbol from glib2-2.14 without having a
dependency on it.
Version-Release number of selected component (if applicable):
xchat-2.8.4-4.fc8.1 and glib2-2.13.6-1.fc8 : doesn't work, unknown symbol
xchat-2.8.4-4.fc8.1 and glib2-2.14.1-1.fc8 : works
please add a
Requires: glib2 >= 2.14
Uh, the fact that compatibility is only one way and software built against more
recent libs won't work with older libs is a well-known fact. This applies not
only to glib2, but also to GTK+, Qt, KDE and even core libs like glibc. XChat
is definitely not the only app affected by such issues. Do we want to hardcode
such requirements in all apps? It would make the automatic soname reqs
essentially useless, as you'd have to add manual Requires for minimum versions
for all libs anyway.
Fedora 8 is going to ship glib2-2.14.1 or newer, so I don't see why this would
be an issue. Running F8 packages on F7 is a bad idea. (And in this case, it's
not like I don't keep the F7 version up to date, I just pushed 2.8.4-5.fc7 to
updates-testing.) And if you use Rawhide and only update parts of it, you get
what you asked for.
*** Bug 344171 has been marked as a duplicate of this bug. ***