Bug 344171 - xchat missing Requires: glib2 >= 2.14
xchat missing Requires: glib2 >= 2.14
Status: CLOSED DUPLICATE of bug 306651
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-20 23:36 EDT by Matt Domsch
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-20 23:43:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2007-10-20 23:36:13 EDT
Description of problem:
xchat-2.8.4-6.fc8 makes calls to g_once_init_enter_impl() from glib2 which does
not exist in glib2 2.12 (as in Fedora 7).  However, it does not have a
"Requires: glib2 >= 2.14", and there was no soname bump between 2.12 and 2.14,
so there's no way updating xchat will pull in the proper copy of glib2
automatically.  xchat fails to start with a message:
xchat: symbol lookup error: xchat: undefined symbol: g_once_init_enter_impl


Version-Release number of selected component (if applicable):
xchat-2.8.4-6.fc8

How reproducible:
didn't try on multiple machines, but on one machine running F7, and upgrading
only xchat (and requisite glibc update), xchat fails to start.
Comment 1 Kevin Kofler 2007-10-20 23:43:42 EDT
This has already been submitted, but there's dozens of other apps which will 
break if you pull in a sufficiently old library version with the same soname 
(glib2 is hardly the only library with one-way compatibility), and Fedora 8 
isn't going to ship any older glib2, so I don't see the point of special-casing 
XChat here (see the discussion in Bug 306651).

*** This bug has been marked as a duplicate of 306651 ***

Note You need to log in before you can comment on or make changes to this bug.