Bug 307051 - DVD drive scan incorrectly identifies /dev/sr0
DVD drive scan incorrectly identifies /dev/sr0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnomebaker (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 10:04 EDT by Gregory Gulik
Modified: 2007-12-06 15:43 EST (History)
1 user (show)

See Also:
Fixed In Version: 116-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 610897 (view as bug list)
Environment:
Last Closed: 2007-12-06 15:43:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Gulik 2007-09-26 10:04:23 EDT
Description of problem:

Upon start-up the default device for an installed DVD drive is /dev/sr0.  The
same thing happens when you select "Scan for devices" it does find the DVD drive
but the "node" is "/dev/sr0".  At least on Fedora 7 there is no /dev/sr0 device.
 The correct device is /dev/scd0

Version-Release number of selected component (if applicable):

gnomebaker-0.6.2-1.fc7

How reproducible:

Always

Steps to Reproduce:
1. Start gnomebaker
2. try to burn a CD or DVD

  
Actual results:

:-( "/dev/sr0=/raid-array2/DVD_IMAGE.ISO": unexpected errno:No such file or
directory
The "no such file or directory" refers to /dev/sr0 because
/raid-array2/DVD_IMAGE.ISO does exist and is readable.

Expected results:

Gnomebaker should be able to find the correct device for the DVD drive and
successfully burn the DVD image.

Additional info:

Every time I start up gnomebaker I have to go to Edit -> Preferences -> Devices
and manually change the device to /dev/scd0.  After I do that gnomebaker works
just fine.
Comment 1 Tomas Smetana 2007-09-26 10:13:59 EDT
GnomeBaker takes the device node from /proc/sys/dev/cdrom/info and it says sr0
on F-7.  This has to be changed so that GnomeBaker takes device name from the
wodim/cdrecord output.
Comment 2 Gregory Gulik 2007-09-26 10:18:31 EDT
Why does /proc/sys/dev/cdrom/info have sr0 in the first place?

Is that incorrect or should there really be a /dev/sr0 device?
Comment 3 Harald Hoyer 2007-10-01 06:53:08 EDT
GnomeBaker can just glob("/dev/cdrom*) or glob("/dev/cdrw*") in rawhide.
Comment 4 Tomas Smetana 2007-10-01 07:16:15 EDT
This problem doesn't occur in rawhide.  In F-7 it's caused by udev that renames
/dev/sr* to /dev/scd* which makes /proc and /dev inconsistent.  The updated udev
should solve the issue.
Comment 5 Fedora Update System 2007-10-03 17:18:57 EDT
udev-115-4.20070921git.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'
Comment 6 Michael Cronenworth 2007-10-04 11:49:47 EDT
The udev-115-4.20070921git.fc7 package leaves /dev/sr0 be and creates a
/dev/scd0 symlink. Works for me. Thanks!
Comment 7 Gregory Gulik 2007-10-05 14:00:49 EDT
The udev-115-4.20070921git.fc7 package fixed the GnomeBaker problem for me.

Thank you for the quick resolution.
Comment 8 Fedora Update System 2007-10-15 17:24:39 EDT
udev-115-5.20071012git.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'
Comment 9 Fedora Update System 2007-11-09 18:55:32 EST
udev-116-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'
Comment 10 Fedora Update System 2007-12-06 15:43:31 EST
udev-116-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.