Bug 610897 - DVD drive scan incorrectly identifies /dev/sr0
DVD drive scan incorrectly identifies /dev/sr0
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 13:15 EDT by Michael J. Carter
Modified: 2011-01-13 18:00 EST (History)
7 users (show)

See Also:
Fixed In Version: udev-095-14.22.el5
Doc Type: Bug Fix
Doc Text:
Prior to this update, udev renamed the '/dev/sr*' device nodes to '/dev/scd*'. This caused some sr* devices nodes (referenced by kernel information such as '/proc/sys/dev/cdrom/info') to be missing. This update creates symbolic links to /dev/scd* and creates the /dev/sr* device nodes.
Story Points: ---
Clone Of: 307051
Environment:
Last Closed: 2011-01-13 18:00:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Carter 2010-07-02 13:15:38 EDT
+++ This bug was initially created as a clone of Bug #307051 +++

Description of problem:

Upon start-up the default device for an installed DVD drive is /dev/sr0.  The
same thing happens when you select "Scan for devices" it does find the DVD drive
but the "node" is "/dev/sr0".  At least on Fedora 7 there is no /dev/sr0 device.
 The correct device is /dev/scd0

Version-Release number of selected component (if applicable):

gnomebaker-0.6.2-1.fc7

How reproducible:

Always

Steps to Reproduce:
1. Start gnomebaker
2. try to burn a CD or DVD

  
Actual results:

:-( "/dev/sr0=/raid-array2/DVD_IMAGE.ISO": unexpected errno:No such file or
directory
The "no such file or directory" refers to /dev/sr0 because
/raid-array2/DVD_IMAGE.ISO does exist and is readable.

Expected results:

Gnomebaker should be able to find the correct device for the DVD drive and
successfully burn the DVD image.

Additional info:

Every time I start up gnomebaker I have to go to Edit -> Preferences -> Devices
and manually change the device to /dev/scd0.  After I do that gnomebaker works
just fine.

--- Additional comment from tsmetana@redhat.com on 2007-09-26 10:13:59 EDT ---

GnomeBaker takes the device node from /proc/sys/dev/cdrom/info and it says sr0
on F-7.  This has to be changed so that GnomeBaker takes device name from the
wodim/cdrecord output.

--- Additional comment from greg@gulik.org on 2007-09-26 10:18:31 EDT ---

Why does /proc/sys/dev/cdrom/info have sr0 in the first place?

Is that incorrect or should there really be a /dev/sr0 device?

--- Additional comment from harald@redhat.com on 2007-10-01 06:53:08 EDT ---

GnomeBaker can just glob("/dev/cdrom*) or glob("/dev/cdrw*") in rawhide.

--- Additional comment from tsmetana@redhat.com on 2007-10-01 07:16:15 EDT ---

This problem doesn't occur in rawhide.  In F-7 it's caused by udev that renames
/dev/sr* to /dev/scd* which makes /proc and /dev inconsistent.  The updated udev
should solve the issue.

--- Additional comment from updates@fedoraproject.org on 2007-10-03 17:18:57 EDT ---

udev-115-4.20070921git.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'

--- Additional comment from mike@cchtml.com on 2007-10-04 11:49:47 EDT ---

The udev-115-4.20070921git.fc7 package leaves /dev/sr0 be and creates a
/dev/scd0 symlink. Works for me. Thanks!

--- Additional comment from greg@gulik.org on 2007-10-05 14:00:49 EDT ---

The udev-115-4.20070921git.fc7 package fixed the GnomeBaker problem for me.

Thank you for the quick resolution.

--- Additional comment from updates@fedoraproject.org on 2007-10-15 17:24:39 EDT ---

udev-115-5.20071012git.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'

--- Additional comment from updates@fedoraproject.org on 2007-11-09 18:55:32 EST ---

udev-116-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'

--- Additional comment from updates@fedoraproject.org on 2007-12-06 15:43:31 EST ---

udev-116-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 1 Michael J. Carter 2010-07-02 13:20:06 EDT
I'm seeing the same issue with a SATA optical drive under RHEL 5.5:

[pvt root@fuggles sabrs]# cat /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:             sr0
drive speed:            48
drive # of slots:       1
Can close tray:         1
Can open tray:          1
Can lock tray:          1
Can change speed:       1
Can select disk:        0
Can read multisession:  1
Can read MCN:           1
Reports media changed:  1
Can play audio:         1
Can write CD-R:         1
Can write CD-RW:        1
Can read DVD:           1
Can write DVD-R:        1
Can write DVD-RAM:      0
Can read MRW:           0
Can write MRW:          0
Can write RAM:          1

No device file for this drive exists:

[pvt root@fuggles dev]# ls -l /dev/sr*
ls: /dev/sr*: No such file or directory

udev has renamed the device:

[pvt root@fuggles dev]# ls -l /dev/scd*
brw------- 1 carter disk 11, 0 Jul  1 11:14 /dev/scd0

[pvt root@fuggles dev]# ls -l /dev | grep scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 cdrom -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 cdrom-sr0 -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 cdrw -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 cdrw-sr0 -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 cdwriter -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 cdwriter-sr0 -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 dvd -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 dvdrw -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 dvdrw-sr0 -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 dvd-sr0 -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 dvdwriter -> scd0
lrwxrwxrwx 1 root   root           4 Jul  1 11:14 dvdwriter-sr0 -> scd0
brw------- 1 carter disk   11,     0 Jul  1 11:14 scd0

Because of this, hald doesn't poll this device.

I'm running latest version of udev for RHEL 5.5:

[pvt root@fuggles dev]# rpm -q udev
udev-095-14.21.el5
Comment 7 Martin Prpič 2010-12-06 09:14:06 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, udev renamed the '/dev/sr*' device nodes to '/dev/scd*'. This caused some sr* devices nodes (referenced by kernel information such as '/proc/sys/dev/cdrom/info') to be missing. This update creates symbolic links to /dev/scd* and creates the /dev/sr* device nodes.
Comment 9 errata-xmlrpc 2011-01-13 18:00:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0073.html

Note You need to log in before you can comment on or make changes to this bug.