Bug 30797 - tcsh > operator truncates files to zero once they grow beyond 2 GB
Summary: tcsh > operator truncates files to zero once they grow beyond 2 GB
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcsh   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 31259 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-06 10:36 UTC by Andreas Helke
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 10:43:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas Helke 2001-03-06 10:36:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; I; Linux 2.2.16 i686)


If you append to a file with   the  tcsh > operator the file gets truncated
to zero lenght as soon as it reaches 2 GB of size. bash > operator works
correctly. 

FTP 

Reproducible: Always
Steps to Reproduce:
1. create a file a few bytes less than 2 GB
2. in tcsh shell run echo "a new text string"  > pretty_big_file
3. 
	

Actual Results:  File consists of xt string only. 2 GB of content are
missing.

Expected Results:  A complete file 

/bin/ftp has problems with big files too it only writes the first 2 GB if I
remember correctly.

Comment 1 Andreas Helke 2001-03-06 10:40:07 UTC
There was a typo in my bug report. I meant the >> operator instead of the >
operator

Comment 2 Eido Inoue 2001-03-14 10:43:51 UTC
*** Bug 31259 has been marked as a duplicate of this bug. ***

Comment 3 Eido Inoue 2001-03-14 10:45:50 UTC
looks like tcsh needs llseek instead of the standard seek... fix appears to be
non-trivial.


Comment 4 Kurt Zingler 2001-04-02 22:42:16 UTC
I have a similar problem with the tcsh.  I cannot get any file size larger than 4GB regardless of the method used to create the file.  
I was actually doing a load to a mysql db at the time.  I cannot seem to get passed the 4GB file size.  If I use bash
the problem goes away.

Comment 5 Kurt Zingler 2001-04-03 01:18:33 UTC
on bash I can build files greater than 4GB without a problem (Fisher and Wolverine).  But to correct my last email, I still cannot 
create mysql tables larger than 4GB.


Note You need to log in before you can comment on or make changes to this bug.