Bug 31259 - tcsh cannot create files > 2GB
tcsh cannot create files > 2GB
Status: CLOSED DUPLICATE of bug 30797
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-09 20:31 EST by Joshua Buysse
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 01:29:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Buysse 2001-03-09 20:31:50 EST
Using the '>' operator to create a file larger than 2GB fails under tcsh
from RC2.  Error is "Filesize limit exceeded (core dumped)".  However,
using the 'limit' command reveals that no fsize limit is set.  Creating the
file using bash is successful.

This is a change from 7.0 -- it worked fine under 7.0-release.  I hadn't
tested this case with earlier betas, so I don't know when the problem was
introduced.

Here's a backtrace from gdb on the core file:

[dumpdisk@danton t]$ dd if=/dev/zero bs=1M count=3072 > foo
Filesize limit exceeded (core dumped)
[dumpdisk@danton t]$ ls
core  foo
[dumpdisk@danton t]$ gdb tcsh
GNU gdb 5.0rh-3 Red Hat Linux 7.1
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) core core
warning: core file may not match specified executable file.
Core was generated by `dd if /dev/zero bs 1M count 3072'.
Program terminated with signal 25, File size limit exceeded.
#0  0x400f4664 in ?? ()
(gdb) bt
#0  0x400f4664 in ?? ()
#1  0x0804a589 in strcpy ()
#2  0x0804acd7 in strcpy ()
#3  0x40041d4c in ?? ()
(gdb)
Comment 1 Joshua Buysse 2001-03-12 01:29:47 EST
See also bug #30797 -- tcsh has very bad behavior on appends (>>) that will
extend a file past 2GB.

The problem reported in 30797 /will cause data loss/.
Comment 2 Eido Inoue 2001-03-14 05:44:00 EST

*** This bug has been marked as a duplicate of 30797 ***

Note You need to log in before you can comment on or make changes to this bug.