Bug 30818 - kudzu not recognizing bcm5700
Summary: kudzu not recognizing bcm5700
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 31070 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-06 16:06 UTC by John A. Hull
Modified: 2014-03-17 02:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 16:04:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hwconf.txt (3.38 KB, text/plain)
2001-03-07 20:54 UTC, Shane Painter
no flags Details
kudzu-version.txt (36 bytes, text/plain)
2001-03-07 20:54 UTC, Shane Painter
no flags Details
hwconf file (3.38 KB, patch)
2001-03-07 20:55 UTC, Danny Trinh
no flags Details | Diff
pcitable.txt (133.02 KB, text/plain)
2001-03-07 21:00 UTC, Shane Painter
no flags Details

Description John A. Hull 2001-03-06 16:06:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)


The installation program doesn't recognize bcm5700.
After installed RC2, kudzu couldn't recognize bcm5700 also.
However, I can manually load bcm5700.o driver and It worked fine. 

Reproducible: Always
Steps to Reproduce:
1. Install RC2
2. Run kudzu
3. Kudzu will not recognize bcm5700
	

Actual Results:  Kudzu did not recognize bcm5700

Expected Results:  Kudzu should recognize bcm5700 and allow for its 
configuration.

Comment 1 Shane Painter 2001-03-06 16:36:09 UTC
Here is the info from /proc/pci, so that you have the PCI IDs...
-Shane

Bus  3, device   8, function  0:
    Ethernet controller: PCI device 14e4:1644 (BROADCOM Corporation) (rev 16).
      IRQ 11.
      Master Capable.  Latency=32.  Min Gnt=64.
      Non-prefetchable 64 bit memory at 0xfea00000 [0xfea0ffff].


Comment 2 Bill Nottingham 2001-03-06 16:43:43 UTC
Please file bugs against the correct product.
(i.e., don't file RC2 bugs against the public beta.)

In any case, this *should* currently work. What does the /etc/sysconfig/hwconf
look like?


Comment 3 Glen Foster 2001-03-06 21:14:10 UTC
We (Red Hat) should really try to fix this before next release.

Comment 4 Bill Nottingham 2001-03-07 20:13:41 UTC
I've tried this with the provided card; it worked OK once I booted a
kernel with the correct module. What exact version of kudzu do you have
installed, and what does your /etc/sysconfig/hwconf look like?

Is the bcm5700 listed in your /usr/share/kudzu/pcitable?

Comment 5 Shane Painter 2001-03-07 20:54:18 UTC
Created attachment 12024 [details]
hwconf.txt

Comment 6 Shane Painter 2001-03-07 20:54:56 UTC
Created attachment 12025 [details]
kudzu-version.txt

Comment 7 Danny Trinh 2001-03-07 20:55:07 UTC
Created attachment 12026 [details]
hwconf file

Comment 8 Bill Nottingham 2001-03-07 20:57:59 UTC
What kernel are you running?

Comment 9 Shane Painter 2001-03-07 21:00:17 UTC
Created attachment 12027 [details]
pcitable.txt

Comment 10 Danny Trinh 2001-03-07 21:03:46 UTC
I'm running on 2.4.2-0.1.19 kernel. This is a single processor server.

Comment 11 Bill Nottingham 2001-03-07 21:07:14 UTC
What happens if you remove the broadcom entry from /etc/sysconfig/hwconf
and re-run kudzu?

Comment 12 Danny Trinh 2001-03-08 15:26:50 UTC
After I remove the broadcom entry from /etc/sysconfig/hwconf, kudzu is working.

Comment 13 Bill Nottingham 2001-03-08 15:40:45 UTC
What kernel was running on this machine the first time it was installed/kudzu
was run?

Basically, all I can guess that happened is that when kudzu first saw the
broadcom card, it didn't find the bcm5700 module for it, so it ignored it.

Comment 14 Bill Nottingham 2001-03-08 16:04:31 UTC
*** Bug 31070 has been marked as a duplicate of this bug. ***

Comment 15 Bill Nottingham 2001-03-10 00:48:29 UTC
Just tested with today's tree; it works OK.

The bits to recognize it in the installer have been committed to CVS; will
be in the next anaconda build.


Note You need to log in before you can comment on or make changes to this bug.