Bug 30818 - kudzu not recognizing bcm5700
kudzu not recognizing bcm5700
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: 31070 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-03-06 11:06 EST by John A. Hull
Modified: 2014-03-16 22:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-08 11:04:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
hwconf.txt (3.38 KB, text/plain)
2001-03-07 15:54 EST, Shane Painter
no flags Details
kudzu-version.txt (36 bytes, text/plain)
2001-03-07 15:54 EST, Shane Painter
no flags Details
hwconf file (3.38 KB, patch)
2001-03-07 15:55 EST, Danny Trinh
no flags Details | Diff
pcitable.txt (133.02 KB, text/plain)
2001-03-07 16:00 EST, Shane Painter
no flags Details

  None (edit)
Description John A. Hull 2001-03-06 11:06:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)

The installation program doesn't recognize bcm5700.
After installed RC2, kudzu couldn't recognize bcm5700 also.
However, I can manually load bcm5700.o driver and It worked fine. 

Reproducible: Always
Steps to Reproduce:
1. Install RC2
2. Run kudzu
3. Kudzu will not recognize bcm5700

Actual Results:  Kudzu did not recognize bcm5700

Expected Results:  Kudzu should recognize bcm5700 and allow for its 
Comment 1 Shane Painter 2001-03-06 11:36:09 EST
Here is the info from /proc/pci, so that you have the PCI IDs...

Bus  3, device   8, function  0:
    Ethernet controller: PCI device 14e4:1644 (BROADCOM Corporation) (rev 16).
      IRQ 11.
      Master Capable.  Latency=32.  Min Gnt=64.
      Non-prefetchable 64 bit memory at 0xfea00000 [0xfea0ffff].
Comment 2 Bill Nottingham 2001-03-06 11:43:43 EST
Please file bugs against the correct product.
(i.e., don't file RC2 bugs against the public beta.)

In any case, this *should* currently work. What does the /etc/sysconfig/hwconf
look like?
Comment 3 Glen Foster 2001-03-06 16:14:10 EST
We (Red Hat) should really try to fix this before next release.
Comment 4 Bill Nottingham 2001-03-07 15:13:41 EST
I've tried this with the provided card; it worked OK once I booted a
kernel with the correct module. What exact version of kudzu do you have
installed, and what does your /etc/sysconfig/hwconf look like?

Is the bcm5700 listed in your /usr/share/kudzu/pcitable?
Comment 5 Shane Painter 2001-03-07 15:54:18 EST
Created attachment 12024 [details]
Comment 6 Shane Painter 2001-03-07 15:54:56 EST
Created attachment 12025 [details]
Comment 7 Danny Trinh 2001-03-07 15:55:07 EST
Created attachment 12026 [details]
hwconf file
Comment 8 Bill Nottingham 2001-03-07 15:57:59 EST
What kernel are you running?
Comment 9 Shane Painter 2001-03-07 16:00:17 EST
Created attachment 12027 [details]
Comment 10 Danny Trinh 2001-03-07 16:03:46 EST
I'm running on 2.4.2-0.1.19 kernel. This is a single processor server.
Comment 11 Bill Nottingham 2001-03-07 16:07:14 EST
What happens if you remove the broadcom entry from /etc/sysconfig/hwconf
and re-run kudzu?
Comment 12 Danny Trinh 2001-03-08 10:26:50 EST
After I remove the broadcom entry from /etc/sysconfig/hwconf, kudzu is working.
Comment 13 Bill Nottingham 2001-03-08 10:40:45 EST
What kernel was running on this machine the first time it was installed/kudzu
was run?

Basically, all I can guess that happened is that when kudzu first saw the
broadcom card, it didn't find the bcm5700 module for it, so it ignored it.
Comment 14 Bill Nottingham 2001-03-08 11:04:31 EST
*** Bug 31070 has been marked as a duplicate of this bug. ***
Comment 15 Bill Nottingham 2001-03-09 19:48:29 EST
Just tested with today's tree; it works OK.

The bits to recognize it in the installer have been committed to CVS; will
be in the next anaconda build.

Note You need to log in before you can comment on or make changes to this bug.