Bug 30876 - Anaconda traceback when XFree86 test is skipped
Anaconda traceback when XFree86 test is skipped
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: 31764 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-03-06 17:52 EST by Brian Brock
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-15 10:52:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda traceback for bug #30876 (skip X configuration test; Anaconda crashes) (824 bytes, text/plain)
2001-03-06 17:54 EST, Brian Brock
no flags Details
traceback for qa0307.0 (824 bytes, text/plain)
2001-03-07 15:22 EST, Brian Brock
no flags Details

  None (edit)
Description Brian Brock 2001-03-06 17:52:41 EST
Anaconda crashes with traceback under (at least) the following

qa0306.0 tree / anaconda-7.1-2.20010305163
text mode
Installation over NFS
laptop installation (Dell Inspiron 3500) 
defaults for all other choices (english, firewall rules, etc.)

On the screen when the X configuration is about to be tested (post- package
installation), select the "skip" button (instead of testing the selected X
configuration) causes the traceback.

Traceback to be attached shortly.

Please let me know if more details are required
Comment 1 Brian Brock 2001-03-06 17:54:09 EST
Created attachment 11948 [details]
Anaconda traceback for bug #30876 (skip X configuration test; Anaconda crashes)
Comment 2 Bill Nottingham 2001-03-06 18:32:26 EST

*** This bug has been marked as a duplicate of 30870 ***
Comment 3 Brian Brock 2001-03-07 15:21:21 EST
Problem still occuring in qa0307.0 tree.  I don't think this is the same as bug
#30870,  if I read Trond's notes right, he chooses a different path than I do in
the installer, and the difference is the cause of my error (and resulting

Attaching traceback for qa0307.0 tree shortly.
Comment 4 Brian Brock 2001-03-07 15:22:31 EST
Created attachment 12002 [details]
traceback for qa0307.0
Comment 5 Glen Foster 2001-03-08 17:55:42 EST
This defect considered MUST-FIX (showstopper) for Florence Gold
Comment 6 Michael Fulbright 2001-03-09 14:59:00 EST
Please test in the qa0309.1 tree, should be fixed.
Comment 7 Brent Fox 2001-03-14 11:02:06 EST
Verified fix in the qa0314.0 tree
Comment 8 Brian Brock 2001-03-14 12:01:09 EST
also verified in qa0309.1, closing.
Comment 9 Brent Fox 2001-03-14 15:33:29 EST
*** Bug 31764 has been marked as a duplicate of this bug. ***
Comment 10 R P Herrold 2001-03-14 16:07:31 EST
... ummm -- my test condition in 31764 was not a striaght skip, but a failed
config ... is the logic path the same (it would seem not ...) and was it tested?
Comment 11 Brian Brock 2001-03-14 18:15:27 EST
Good point.  The laptop that I opened this bug on originally failed
Xconfigurator, it now (as of today's build) works properly, so your case for
#31764 was not tested fully.
Comment 12 Brian Brock 2001-03-14 18:16:54 EST
... make that not tested directly by me.
Comment 13 R P Herrold 2001-03-14 21:15:03 EST
Re-open for confirmation of tested path on failed rather than skipped Xconfigurator
Comment 14 Brent Fox 2001-03-15 10:52:52 EST
The logic path is the same.  The original bug was trying to unlink a file that
wasn't there...

Note You need to log in before you can comment on or make changes to this bug.