Bug 3097 - DHCPCD is not installed correctly by RPM. Thus causing some problems,
DHCPCD is not installed correctly by RPM. Thus causing some problems,
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 3132 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-27 13:11 EDT by kislo
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-29 11:23:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kislo 1999-05-27 13:11:37 EDT
The DHCPCD program does not get installed properly.  For
the DHCPCD program to work properly, the directory
/etc/dhcpc must exist.  Without this directory, dhcpcd
*will* operate, but will not be able to store it's cache or
info files.  Which will cause slight problems down the road
when it needs to renew it's IP address (IE the machine is
left on enough that the daemon is required to renew the ip
address). Simply creating /etc/dhcpc solves this problem,
and when you run dhcpcd it will place it's files in there
correctly.
Comment 1 Jeff Johnson 1999-05-29 11:23:59 EDT
Fixed (by including /etc/dhcpc) in dhcpcd-1.3.17pl2-2. I also
put a copy of dhcpcd-eth0.exe into the dhcpcd doc directory.
Comment 2 Jeff Johnson 1999-05-29 11:48:59 EDT
*** Bug 3132 has been marked as a duplicate of this bug. ***

I've been using, with RH 5.2, ipchains rules and scripts as
written by Robert Zeigler:

	http://rlz.ne.mediaone.net/linux/faq/index3.html

Unfortunately, under 6.0, the dhcpcd interface information
file is no longer created, so ipchains rules use the
IP address I had weeks ago and thus don't work.

Why was this removed, or what has it been changed to?
I don't see anything in the ipup script (besides running
pump to manage the DHCP requests) to allow me to fix this,
short of writing my own script to extract this information
from output of pump.  This seems like a bug to me, since
getting this information from dhcpcd is critical for
using ipchains.  Please fix this.

Thanks very much.
--
Dave Dittrich
dittrich@cac.washington.edu

------- Additional Comments From jbj@redhat.com  05/29/99 11:47 -------
I believe that
	mkdir /etc/dhcpc
the info file may once again be created. If I'm wrong, then
please reopen this bug.

------- Email Received From  Dave Dittrich <dittrich@cac.washington.edu> 06/02/99 19:59 -------


------- Email Received From  Dave Dittrich <dittrich@cac.washington.edu> 06/06/99 20:52 -------

Note You need to log in before you can comment on or make changes to this bug.