Bug 30974 - Problem configureing SIS6326 card
Problem configureing SIS6326 card
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 30975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 13:49 EST by Henry McBride
Modified: 2007-04-18 12:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-18 15:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x server log (18.74 KB, text/plain)
2001-03-17 02:51 EST, Henry McBride
no flags Details
X server output (6.39 KB, text/plain)
2001-05-18 04:26 EDT, Tim Waugh
no flags Details

  None (edit)
Description Henry McBride 2001-03-07 13:49:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


The display appears grey and you can see a grey box for the cursor and no 
text at all. This is unlike Redhat 7 which this same setup works fine.

Reproducible: Always
Steps to Reproduce:
1.select the SIS 6326 video card
2.Select Impression 7 monitor
3.run test xconfig
	

Actual Results:  The test screen had a background but the cursor was a 
grey box and so was the message screen. No text was visible

Expected Results:  you should have seen the actual screen and a message 
asking you if you like the screen settings
Comment 1 Preston Brown 2001-03-07 15:25:15 EST
*** Bug 30975 has been marked as a duplicate of this bug. ***
Comment 2 Brian Brock 2001-03-07 17:07:54 EST
Tested using the latest internel tree, using a GUI installation.

The card appeared to work well by default in that case,  X and gdm started in
runlevel 5 post-installation, without any video corruption.  No video corruption
while running X for 5-10 minutes and running arbitrary GUI applications in X.

changed to runlevel 3 after that test, and encountered problems running
Xconfigurator... All resolutions at 24bpp would either not start (with text
complaint that there is a problem with the X configuration, and back / quit
buttons), or X would start with the video corruption mentioned above.

Will give specific details after more testing, please let me know if there is
specific data needed.
Comment 3 Brian Brock 2001-03-07 18:22:20 EST
Xconfigurator (with no options) result in good configurations at the following
resolutions and color depths:

8bpp: 1024x768, 800x600
16bpp: 1024x768, 800x600

some resolutions appear without substantial corruption, but clip the edge of the
screen (as if the virtual resolution doesn't match the display).  These are
basically useable, maybe xvidtune can get them better.  Could that be blamed
easily on the monitor?:
8bpp: 1280x1024, 1152x864, 1400x1050
16bpp: 1280x1024, 1152x864, 640x480

the following can't be tested (Xconfigurator gives up, telling the user that
there is a problem with the X configuration, and prompting with back / quit
buttons):
8bpp: 1600x1200, 640x480
16bpp: 1600x1200, 1400x1050
24bpp: 1024x768

In 24bpp, 800x600 and 640x480 display, with severe video corruption (display
completely unusable).  testing 1152x864 at 24bpp results in a display of 640x480
at 16bpp.
Comment 4 Mike A. Harris 2001-03-14 01:58:38 EST
Please attach your X server logs and XF86Config-4 to the bugzilla report
using the attachment link below.
Comment 5 Henry McBride 2001-03-17 02:51:24 EST
Created attachment 12863 [details]
x server log
Comment 6 Mike A. Harris 2001-03-18 23:11:15 EST
I don't see any failures in your server log.  Can you reproduce the problem and
send me the log from that, and also your XF86Config-4 file, both as attachments.

Thanks.
Comment 7 Mike A. Harris 2001-04-01 08:12:19 EDT
Defered waiting for more detailed information.
Comment 8 Tim Waugh 2001-05-18 04:15:50 EDT
I see this problem with a "Silicon Integrated Systems [SiS] 86C326 (rev
0b)".
Comment 9 Tim Waugh 2001-05-18 04:26:00 EDT
Created attachment 18870 [details]
X server output
Comment 10 Jerry Rabe 2001-05-18 15:23:25 EDT
I also have problems with my 8 MByte SIS 6326 card.  The RedHat installer
finds the card OK, but thinks it only has 4 MBytes of memory.  I have tried
every combination of 4MByte, 8MByte, 8/16/24 bit color, and every resolution
from 1024x768 on up.  The only combinations that displays properly is 1024x768
at 8/16 bits (either 4MByte or 8MByte).  Higher resolutions produce artifacts
and/or a wrapped screen image where you see the desktop icons on the right
side of the screen as well as the left side.  Testing 24 bit color does not
even display these artifacts, only a black screen until the timeout.

Windows has no problem with this card even up to 1600x1200 resolution.
Comment 11 Mike A. Harris 2001-06-01 18:45:26 EDT
Original bug reporter has indicated via email that enabling the "noaccel" option
in the config file has solved this problem for him.

Note You need to log in before you can comment on or make changes to this bug.