Bug 31057 - lpd no longer works, many problems
lpd no longer works, many problems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
: 31058 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 05:45 EST by Levente Farkas
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-10 04:41:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2001-03-08 05:45:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.14 i686)


the old printcap file do not converted to the new format, and the even
if I change it by hand it's no longer works (see results). I even try to
use the new printtool (which is far worse then the old one, at least I cant
find old options eg. on out HP lj5M I use 2 pages per output pages which
simple disappear, sad:-((). after I reconfigure the printers those still
not work.
when I restart lpd I always get:
-------------------------
Stopping lpd:                                              [  OK  ]
Starting lpd: Warning - 'if' filter '/var/spool/lpd/hp5m/filter' does not
have execute perms
Warning - 'if' filter '/var/spool/lpd/canon/filter' does not have execute
perms
                                                           [  OK  ]
-------------------------
but when I change the permission from 600 to 700 and restart again:
-------------------------
Stopping lpd:                                              [  OK  ]
Starting lpd: Warning - permissions of 'filter' are 0700, not 0600
Warning - 'if' filter '/var/spool/lpd/hp5m/filter' does not have execute
perms
Warning - 'if' filter '/var/spool/lpd/canon/filter' does not have execute
perms
                                                           [  OK  ]
-------------------------

Reproducible: Always
Steps to Reproduce:
1. upgarde from 7.0
2. try to print
3. restart lpd
	

Actual Results:  I see such logs:
-------------------
Printer: hp5m@garfield (dest hp5m@hp5m.inside)
 Queue: no printable jobs in queue
 Status: subserver pid 1213 exit status 'JFAIL' at 10:28:39.950
 Filter_status: sending to hp5m.inside
Printer 'hp5m@hp5m.inside' - cannot open connection - Connection refused
------------------
there is no user required for printing, so I don't know from where lpd find
out the hp5m user ???
------------------
Status: IF filter 'mf_wrapper' filter msg - 'closing *main::KID3' at
19:35:44.289
Status: IF filter 'filter' filter msg - 'Make_passthrough: pid 1214, execve
'/var/spool/lpd/hp5m/filter' failed - 'Permission denied'' at 10:27:52.959
 Status: IF filter 'filter' filter exit status 'JABORT' at 10:27:52.959
------------------
....

Expected Results:  I able to print:-)
Comment 1 Bill Nottingham 2001-03-08 11:19:57 EST
*** Bug 31058 has been marked as a duplicate of this bug. ***
Comment 2 Glen Foster 2001-03-08 17:56:47 EST
We (Red HAT) should really fix this before next release.
Comment 3 Levente Farkas 2001-03-09 03:57:05 EST
I you need further log files I can send (but now I downgrade to the rh 7.0's
version of lpd since I need printing).
Comment 4 Levente Farkas 2001-03-09 04:21:04 EST
even downgrade don't help:
# /etc/init.d/lpd start
Starting lpd: /usr/sbin/checkpc: error while loading shared libraries:
/usr/sbin/checkpc: undefined symbol: stat
/usr/sbin/lpd: error while loading shared libraries: /usr/sbin/lpd: undefined
symbol: stat
                                                           [FAILED]
Comment 5 Crutcher Dunnavant 2001-03-09 16:07:53 EST
This is an upgrade case.
It is a problem that was fixed (i believe) since Wolverine.

Please try the rpms available at:
http://people.redhat.com/crutcher/printing

And tell me if they fix your problem.
Comment 6 Levente Farkas 2001-03-10 04:20:16 EST
there is no i386.rpm for groff and netpbm, but I jsut downloading and try the
otrhers...
Comment 7 Levente Farkas 2001-03-10 04:41:37 EST
ok. so it's finaly working:-)
BUT it's still worse (for me) then the old printtool, since there are a few
missing feature. eg: I'm not able to print two pages to one page (there was a 
radio button in the old printtool) and some other features.
IMHO it's be nice to be able to set some postcript features in printtool.
I usualy print source codes and in this case the two pages on one are very
useful.

Note You need to log in before you can comment on or make changes to this bug.