Bug 31059 - not upgrade rather install
not upgrade rather install
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 31060 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 05:52 EST by Levente Farkas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 09:54:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2001-03-08 05:52:13 EST
hi,
when I upgade from rh 7.0 installer do not upgrade rather install postfix
which means two version were installed after upgrade. (the previous version
was from rh 7.0's powertools) nad I have to remove the older one by
hand:-(((
Comment 1 Bernhard Rosenkraenzer 2001-03-08 06:27:45 EST
This has nothing to do with the package itself. use rpm -U, not rpm -i, to 
update.

Comment 2 Levente Farkas 2001-03-08 06:38:37 EST
I like when the first response assume I'm such a beginer:-)
I use rpm -Fvh *.rpm in the our local redhat/powertools/wolverine/RedHat/RPMS
directory :-)
Comment 3 Bernhard Rosenkraenzer 2001-03-08 06:43:46 EST
Then either your rpm database is messed up or there's some strange bug in rpm.
Assigning to rpm
Comment 4 Bernhard Rosenkraenzer 2001-03-08 06:44:35 EST
*** Bug 31060 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Johnson 2001-03-08 08:58:06 EST
Check to make sure that you don't have two postfix packages installed by the
splat in "rpm -Fvh *".

Otherwise I need a reproducible test case if you wish me to take a look. Please
reopen
this bug if you can reproduce the problem.
Comment 6 Levente Farkas 2001-03-08 09:06:02 EST
what does this "installed by the splat in "rpm -Fvh *" ?
and how can I "if you wish me to take a look" ?
I'm not anative english speaker:-(((
further info:
---------------------
[lfarkas@ai:/mnt/download/mirror/redhat/powertools/wolverine/RedHat/RPMS]ls
postfix*
postfix-20010202-3.i386.rpm
---------------------
so there is just one postfix in that directory (and if you belive me there was
just one postfix installed before 7.0.91). the original system was a fully
updated 7.0. there are just two packages postfix and wine which were duplicated
after upgrade.
one more note both packages has some problem running the postinstall script
during rpm -Fvh (postfix can't find myhostname..., wine has some config file
problem).
may this couse the problem ?
Comment 7 Jeff Johnson 2001-03-08 09:16:37 EST
Apologies. By "splat" I meant the wildcard glob character *, asterisk.

I need more info on how two postfix packages came to be installed.

Usually, multiple packages end up being installed because -i was
used rather than -U, or because a wildcard included two packages
in the same transaction set. I don't know of any "strange bugs"
in rpm that lead to the behavior you see.

Can you supply the exact package names for postfix and rpm
that you had installed? If so, I'll try to reproduce the bug.
Comment 8 Levente Farkas 2001-03-08 09:29:24 EST
I know about -i <-> -U and that was the reason why I wrote this bug.
I'm sure about rpm -Fvh *.rpm
currently:
postfix-20010202-3
previously? I don't know, but it have to be from rh 7.0's powertools 20000531-7
or may be rh's rawhide, but I'm 99% that it was 20000531-7. there is a
/tmp/update.log but unfortunately there is no log for rpm -Fvh *.rpm :-(
if you now any place from where I can find out the previous version tell me
(/var/log/maillog don't contain version info and I have no more tipps).
rpm was 4.0.2 (which was upgraded during wolvorine upgrade) at that time,
but now I downgrade to 4.0 since ximian said the incompatibility between 4.0 
and 4.0.2 was the reason behind red-carpet's crash (after upgrade to wolvorine
:-( another sad thing).
Comment 9 Jeff Johnson 2001-03-08 09:54:05 EST
OK, -F is exactly the same as -U with the additional install policies:
	Skip this package if the package is not currently installed.
	Skip this package if a newer version is already installed.

There is no history log for the rpm command line other than redirecting
stdout/stderr, sorry.

As for ximian and rpm-4.0.2, the resolution (I believe) is going to be to get
ximian
to use rpm-4.0.2. That work is underway. Meanwhile, either don't use rpm-4.0.2,
or
apply a couple 1 line patches to rpm-4.0 and rebuild ximian against rpm-4.0.

Checking postfix package upgrades, back in a moment ...
Comment 10 Jeff Johnson 2001-03-08 10:04:08 EST
I'm able to upgrade postfix-20000531-7 (from 7.0 powertools) to 
postfix-20010202-4 (from 7.1 powertools) using "rpm -Fvh" from
the command line without problem, and there's only a single entry
in the database.

I'm going to close the bug with WORKSFORME. However, if
you do see the problem again, or can think of a better test to
reproduce the problem, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.