Bug 31064 - RFE: Add visual feedback during "badblocks" checking
RFE: Add visual feedback during "badblocks" checking
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
: 50859 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 07:38 EST by Bill Crawford
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2001-03-08 07:38:36 EST
When the "check for bad blocks while formatting" check box is selected, the
progress bar for disk formatting appears, but there is no visible progress
at all while the badblocks check is running, leading some people to believe
the installer has crashed/frozen at this point.  Some feedback, even if
just a warning about this, would be useful.

An RFE for the future would be a progress bar for the bad blocks checking,
also referring to it as a "surface scan" would help those moving from WinXX
background to understand what was going on.  Even better, add support for
read-write bad block checking for the really paranoid or those with older
disks, and label the checkbox(es) with a "WARNING: this takes a long time"
or similar.

Also some other warnings about the bits that take a long time on older
machines would be handy, just to let people know they should go make
tea/coffee when the installer is searching for packages or checking
dependencies.  This is especially important when doing e.g. FTP
install/upgrade, which is noticeably slower (by a factor of three or more)
at some stages.
Comment 1 Michael Fulbright 2001-03-08 11:52:55 EST
Will consider for future releases.
Comment 2 Bill Crawford 2001-03-08 12:43:05 EST
There has already been a complaint about this on the Wolverine mailing list, and
I have always found this annoying.  The problem is that new users will probably
think the install has hung (it's quite possible some of the reported "installer
hangs" are due to this or maybe other places where feedback is missing).

All that is needed as a quick fix is a one-line warning on the screen that bad
block checking will take a while, surely?
Comment 3 Michael Fulbright 2001-03-08 15:56:43 EST
This will be considered next release.
Comment 4 Jeremy Katz 2002-01-21 20:10:45 EST
*** Bug 50859 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2002-02-28 23:01:28 EST
Fixed in CVS
Comment 6 Red Hat Bugzilla 2006-02-21 13:47:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.