Bug 31094 - Konqueror: very poor default fonts
Summary: Konqueror: very poor default fonts
Status: CLOSED DUPLICATE of bug 18855
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-08 19:15 UTC by Chris Evans
Modified: 2007-04-18 16:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 21:36:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows gross font problem with XFree86-ISO8859-7-Type1-fonts installed (158.11 KB, image/jpeg)
2001-04-04 01:05 UTC, Chris Evans
no flags Details

Description Chris Evans 2001-03-08 19:15:51 UTC
This is with Wolverine.
.
Fire up KDE and fire up konqueror. The default is non anti-aliased
fonts. Make sure this is the case to observe the ugly fonts.
.
Go to http://slashdot.org/
Look at the article headings - the font is very poor and ugly. Characters
run into one another and the whole thing is blocky.
Even without anti-aliased fonts, Linux can do much much better than
this!
I wouldn't recommend putting on anti-aliasing by default because it is
resource intensive.
.
Tim Waugh suggested that this could be because I don't have 100dpi-fonts
installed. I've checked, and I do have them installed.
.
This is not the same issue as the Abiword issue either (as a recap, if
Abiword is installed, then Netscape renders ugly blocky fonts).

Comment 1 Preston Brown 2001-03-08 20:45:28 UTC
can you please do a chkfontpath --list?

Comment 2 Chris Evans 2001-03-08 20:52:41 UTC
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/75dpi
8: /usr/X11R6/lib/X11/fonts/100dpi
9: /usr/share/fonts/default/Type1
10: /usr/share/fonts/default/TrueType
11: /usr/X11R6/lib/X11/fonts/latin2/Type1
12: /usr/share/fonts/ISO8859-7/misc:unscaled
13: /usr/share/fonts/ISO8859-7/misc
14: /usr/share/fonts/ISO8859-7/Type1
15: /usr/share/fonts/ISO8859-9/misc:unscaled
16: /usr/share/fonts/ISO8859-9/misc

Comment 3 Chris Evans 2001-03-08 21:11:01 UTC
Aha
Got the culprit.
.
rpm -e XFree86-ISO8859-7-Type1-fonts
.
And the fonts look OK again. Very strange - they are low in the
fontpath pecking order.

Comment 4 Bernhard Rosenkraenzer 2001-03-16 12:13:12 UTC
This should be fixed in 2.1-10 (it sets the correct charset for your language).



Comment 5 Chris Evans 2001-04-04 01:05:24 UTC
Created attachment 14563 [details]
Shows gross font problem with XFree86-ISO8859-7-Type1-fonts installed

Comment 6 Chris Evans 2001-04-04 01:11:02 UTC
Sorry I have to re-open.
Not fixed with qa0401.
.
Take a look at the .jpg I just uploaded. It shows two
xmag's of Konqueror rendering slashdot.org.
One xmag is with XFree86-ISO8859-7-Type1-fonts 
installed and the other is without. Guess which is
which :-) As we can see, the fonts rendered with that
package installed are very very poor.
.
But wait. There is more. I just tracked down _another_
set of fonts, which when installed, cause ugly font
rendering. The faulty fonts are this time from "abiword".
Damn Abiword fonts! They also make Netscape render
very ugly fonts.
.
It would be great if a full install of RH7.1 manages
to still render pleasant fonts. I really do think
that these ugly font issues make Linux look pretty
lousy to newcomers.


Comment 7 Pekka Savola 2001-04-08 23:51:07 UTC
This was perhaps related: #13889.
Also, Abiword: #18855

Comment 8 Chris Evans 2001-08-06 21:35:58 UTC
Still bust in RH7.2beta3
At _least_ the poxy Abiword fonts are still causing trouble.
rpm -e abiword made web browsing tolerable again :-)


Comment 9 Bernhard Rosenkraenzer 2001-08-29 11:02:18 UTC

*** This bug has been marked as a duplicate of 18855 ***


Note You need to log in before you can comment on or make changes to this bug.