Bug 311201 - Rgmanager treats qdisc as a node
Rgmanager treats qdisc as a node
Status: CLOSED DUPLICATE of bug 223230
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-28 11:37 EDT by Nick Strugnell
Modified: 2009-04-16 18:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 11:50:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Strugnell 2007-09-28 11:37:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.12) Gecko/20070718 Red Hat/1.5.0.12-3.el5 Firefox/1.5.0.12

Description of problem:
This is an anecdotal bug. Unfortunately I do not have the capability to reproduce this but I would be grateful if someone could attempt to reproduce.

In a cluster using qdisc and either no failover domains, or unrestricted failover domains, rgmanager does not distinguish between real nodes and the qdisc. This results in rgmanager trying to start services on the qdisc, which obviously cannot happen.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1. Set up a cluster with qdisc
2. Configure services running in either an unrestricted domain or no domain.
3. Fail nodes until the service tries to migrate to the qdisc.

Actual Results:
rgmanager tried to migrate service to the qdisc

Expected Results:
rgmanager should not treat qdisc as a node

Additional info:
I presume that a workaround would be to use restricted failover domains to prevent a service ever being migrated to the qdisc.

I'm putting this a high severity as it could potentially result in loss of service which clearly isn't acceptibly in an HA service.
Comment 1 Nick Strugnell 2007-09-28 11:50:17 EDT

*** This bug has been marked as a duplicate of 223230 ***
Comment 2 Nate Straz 2007-12-13 12:18:54 EST
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Note You need to log in before you can comment on or make changes to this bug.