Bug 311871 - icewm requires redhat-artwork
icewm requires redhat-artwork
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: icewm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
:
Depends On: 305561
Blocks: ArtworkSplit
  Show dependency treegraph
 
Reported: 2007-09-28 17:50 EDT by Ray Strode [halfline]
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 12:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2007-09-28 17:50:08 EDT
Hi,

I'm trying to get rid of redhat-artwork (see bug 305441).  

Do you know what icewm needs redhat-artwork for?

Could you change the requires to one or more of:

bluecurve-classic-metacity-theme
bluecurve-gdm-theme
bluecurve-gnome-theme
bluecurve-gtk-themes
bluecurve-icon-theme
bluecurve-metacity-theme
bluecurve-xmms-skin
fedorabubbles-gdm-theme
fedoradna-gdm-theme
fedoraflyinghigh-gdm-theme
fedora-gnome-theme
fedora-icon-theme
gtk-bluecurve-engine

?
Comment 1 Gilboa Davara 2007-09-29 02:01:21 EDT
Hi,

IceWM uses a number of bluecurve icons for it's default tool bar icons.
(Terminal/shell/browser)
I assume that the change is -devel only, right?

- Gilboa
Comment 2 Ray Strode [halfline] 2007-09-29 12:08:32 EDT
Right we're only making this change for Rawhide/F8.
Comment 3 Gilboa Davara 2007-10-05 19:14:07 EDT
Before I make the change... which package will provide the default
browser/terminal/etc icons?

- Gilboa
Comment 4 Ray Strode [halfline] 2007-10-09 11:01:44 EDT
fedora-icon-theme provides the redhat-* icons in /usr/share/pixmaps
Comment 5 Gilboa Davara 2007-10-10 06:29:15 EDT
OK. I'll wait for bluecurve-icon-theme (also required by the menu generator) to
be ACCEPTED, before releasing a redhat-artwork-less icewm.

- Gilboa
Comment 6 Ray Strode [halfline] 2007-10-10 09:48:56 EDT
It passed review a while ago.  Also, you don't need to wait because
redhat-artwork  contains virtual provides today.
Comment 7 Gilboa Davara 2007-10-11 08:59:41 EDT
I'm having problem with missing sym-links in bluecurve-icon-theme. [1]
Is it intentional?

- Gilboa
[1] http://permalink.gmane.org/gmane.linux.redhat.fedora.devel/65968
Comment 8 Ray Strode [halfline] 2007-10-11 09:42:20 EDT
No, that's an oversight.  I'll look into it shortly.
Comment 9 Gilboa Davara 2007-10-11 11:49:38 EDT
Thanks.

Let me know when a fixed RPM is out.
I'll release the new IceWM shortly.

- Gilboa

Note You need to log in before you can comment on or make changes to this bug.