Bug 312021 - Cyrillic (UTF-8, non-latin1) letters are lost after a while
Cyrillic (UTF-8, non-latin1) letters are lost after a while
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Database (Show other bugs)
2.18
All All
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-28 20:05 EDT by Doncho N. Gunchev
Modified: 2013-06-23 22:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-24 18:06:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-09-28 20:05:36 EDT
Description of problem:
Some bugs, that contain non-latin1 letters (ex: cyrillic) display OK 
initially, but after a while all non-latin1 letters turn into '?'s.


How reproducible:
Rarely

Steps to Reproduce:
1. Enter a bug in bugzilla.redhat.com
2. Wait a while (weeks/months)
3. Check the bug back
  
Actual results:
Sometimes the non-latin1 letters of the bug report are lost (and replaced 
with '?'s)

Expected results:
All text in UTF-8 to prevent such losses.

Additional info:
You may check Bug 240087 Comment 3. These '?'s were all cyrillic letters and 
they were fine. These days bugzilla suffered a crash and when I checked the 
bug back... I am guessing this can be caused by a bad database backup/restore.
Comment 1 Doncho N. Gunchev 2007-11-10 10:45:08 EST
Hmm, Bug 240087 Comment 3 is fixed somehow, no bug?
Comment 2 Doncho N. Gunchev 2008-02-24 18:06:52 EST
I'm closing this one - no responses and no problems any more.

Note You need to log in before you can comment on or make changes to this bug.