Bug 312291 - [PATCH] Authconfig crashes when started w/o opts in the CLI (non-English locale)
[PATCH] Authconfig crashes when started w/o opts in the CLI (non-English locale)
Status: CLOSED DUPLICATE of bug 237956
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On: 314061
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-29 08:27 EDT by Andy Shevchenko
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 11:46:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Hack to avoid the crash. (763 bytes, patch)
2007-09-29 08:27 EDT, Andy Shevchenko
no flags Details | Diff

  None (edit)
Description Andy Shevchenko 2007-09-29 08:27:54 EDT
Description of problem:
Starting authconfig from CLI (non-English locale) w/o opts should produce the 
help screen, but it just crashes.

Version-Release number of selected component (if applicable):
Last official authconfig for F7.

How reproducible:
Start following in the CLI:
LANG=ru_RU.UTF-8 LC_MESSAGES=ru_RU.UTF-8 authconfig

Additional info:
Please, review and include attached patch.
In depth problem still present for all python-based applications. The optparse 
module contains some broken logic (for non-ascii people). More prefered way is 
to fix python module instead of hack authconfig and possible others.
Comment 1 Andy Shevchenko 2007-09-29 08:27:55 EDT
Created attachment 211321 [details]
Hack to avoid the crash.
Comment 2 Andy Shevchenko 2007-10-01 11:46:18 EDT

*** This bug has been marked as a duplicate of 237956 ***

Note You need to log in before you can comment on or make changes to this bug.