Bug 31255 - RFE: support installing from loopback mounted ISOs
RFE: support installing from loopback mounted ISOs
Status: CLOSED DUPLICATE of bug 29811
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-09 19:33 EST by Chan Cao
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 16:14:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chan Cao 2001-03-09 19:33:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


When I tried to do ftp install I get missing tetex-latex..and the install 
hangs.  I downloaded the iso's and loop-mounted them.  Only later, I 
realized that the ftp install is for installing from ftp sites...I realize 
this may be design...but I would imagine people without CD-ROM doing ftp 
install may run into problem...possible fixes would be to squeeze these 
files onto the first cd.  There were only a few files involved.  Or 
instruction to warn people that ftp install is specifically for "ftp site 
dists"

Also, It's too slow to access bugzilla...could you host it at akamai or 
something...Redhat sites are way slow...this is part of marketing you do 
to promote your product in a fast, accessible manner, I guess.  MS does it 
well.  Also try to move away from FTP as method of distribution...perhaps 
HTTP is the way.  ftp hangs browser for a while because it's not threated, 
I guess.

also, the install program seems to misbehave in many places..the go back 
options was there but the changes/update information would make install 
crash or misbehave.

Reproducible: Sometimes
Steps to Reproduce:
1.s
2.
3.
Comment 1 Michael Fulbright 2001-03-20 12:10:14 EST
If I understand your bug report, the fix is to copy both CDs into a single
directory. We do not support loopback mounting the images at this time.
Comment 2 Chan Cao 2001-03-20 12:32:12 EST
You're right.  I started writing the last paragraph when I realize I need to 
write this.  I'm just trying to say that you could solve a lot of confusions 
and support calls just by doing what I think is common sense...of course that's 
just my opinion.  Your product should look good from the beginning...at the 
install phase and you should try to make it bulletproof as much as 
possible...Just think of some of these review articles, the first thing they 
mention is how easy a time they had to install the product.  If due to their 
mistakes or whatever, it didn't go smoothly, chances are the rest of the review 
isn't very positive for that product.  Maybe this should be passed to a manager 
to review.  If you think this is redundant, then I'm not going to argue because 
the reason you gave that loop mounting is not yet supported.  it's correct, 
it's working/(breaking) as it should.

This fix could be as easy as determining the rpm's needed for successful 
laptop, server and destop installs.  The rest of the files can be pushed back 
to the second CD.  Then if someone does a custom install and the rpm's aren't 
on the first CD, you can tell them right off or suggest to copy or specify 
where the loop mount of the 2nd cd is.  at the beginning, not at the near end 
of install.
Comment 3 Michael Fulbright 2001-03-21 15:30:41 EST
We'll definately consider added support for loopback mounted ISOs in future
releases. It has simply been a matter of time.
Comment 4 Michael Fulbright 2001-04-11 16:14:56 EDT

*** This bug has been marked as a duplicate of 29811 ***

Note You need to log in before you can comment on or make changes to this bug.