Bug 29811 - Anaconda should be smarter about source paths for FTP installs
Anaconda should be smarter about source paths for FTP installs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
: 31237 31255 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 14:19 EST by Scott Russell
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-21 16:47:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Russell 2001-02-27 14:19:11 EST
As it works today to do a network install with Anaconda both of the
/RedHat/RPMS/ directories from CD1 and CD2 must be combinded into a single
directory and made available for the install.

This sucks because it requires copying the packages to the install server
instead of being able to loop mount the ISO image into the install source
tree. (For example into /var/ftp/pub/RedHat71/cdrom1/ and
/var/ftp/pub/RedHat71/cdrom2/)

Instead of assuming that all files are in the same tree Anaconda should
when installing a file:

Check the existing source path for the next file. 
Check one dir back under an expected name. (ie: if installing from
ftp://source.server.com/pub/RedHat/cdrom1/ the installer should check
../cdrom2/)

If either of these two checks turn up the expected file the installer
should continue assuming all files reside in the newly found path. In the
event that no file was found at the expected location or in the assumed new
location the installer should prompt the user for a new path to the source
file.

Using this method you would still have the advantage of being able to start
and install and walk away from the box either by merging the /RedHat/RPMS/
directories into one source tree or by arranging the source tree in a
predfined method such as mounting cds under /cdrom1, /cdrom2, etc.
Comment 1 Michael Fulbright 2001-02-27 18:18:07 EST
This suggestion is one our lists of things to consider for future releases.
Comment 2 Michael Fulbright 2001-04-11 16:14:51 EDT
*** Bug 31255 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2001-04-11 16:15:15 EDT
*** Bug 31237 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2001-09-21 16:48:35 EDT
This works in Roswell, the beta for the next release of Red Hat Linux (although
the paths used are disc1 and disc2 if I remember correctly -- the README and
RELEASE-NOTES say for certain).

Note You need to log in before you can comment on or make changes to this bug.