Bug 312691 - fontforge: use xdg-open instead of htmlview
fontforge: use xdg-open instead of htmlview
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: EasyFix, Patch, Reopened
: 407951 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-29 17:21 EDT by Ville Skyttä
Modified: 2008-03-03 16:25 EST (History)
1 user (show)

See Also:
Fixed In Version: 20080203-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 16:25:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-09-29 17:21:55 EDT
fontforge could use the standard xdg-open instead of the proprietary htmlview
when opening a browser.  Also submitted upstream, patch is at
http://sourceforge.net/tracker/index.php?func=detail&aid=1804883&group_id=103338&atid=634533
Comment 1 Kevin Fenzi 2007-10-07 15:54:21 EDT
Thanks for the bug report. I will see about applying the patch or something like
it. 
Comment 2 Ville Skyttä 2007-12-02 13:51:06 EST
*** Bug 407951 has been marked as a duplicate of this bug. ***
Comment 3 Kevin Fenzi 2008-03-02 11:38:39 EST
Upstream applied this a while ago, and we should be updated now to a version
that has it. ;) 

Feel free to re-open or file a new bug if you spot any issues with it. 
Comment 4 Ville Skyttä 2008-03-02 17:02:57 EST
Well, the specfile still has "Requires: htmlview"; that should be changed to
"Requires: xdg-utils".
Comment 5 Kevin Fenzi 2008-03-02 20:07:39 EST
Sigh. I know I changed it when I was tweaking the spec, but that change got lost
somewhere in my testing. ;( 

Anyhow, change checked in and building now... can you check and confirm that
it's really fixed and close this if so? :) 
Comment 6 Ville Skyttä 2008-03-03 16:25:30 EST
I have no Rawhide box to test with, but the specfile looks good now.

Note You need to log in before you can comment on or make changes to this bug.