Bug 312751 - fbdev + radeonfb + overlapped xterm = screen corruption
fbdev + radeonfb + overlapped xterm = screen corruption
Status: CLOSED DUPLICATE of bug 332791
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-fbdev (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-29 18:08 EDT by Lev Melnkovsky
Modified: 2008-02-18 18:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-18 18:30:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
terminal screenshot taken with GIMP (10.81 KB, image/png)
2007-09-29 18:08 EDT, Lev Melnkovsky
no flags Details
sample xorg.conf (397 bytes, text/plain)
2007-10-02 15:29 EDT, Lev Melnkovsky
no flags Details
...and the logfile (17.22 KB, text/plain)
2007-10-02 15:30 EDT, Lev Melnkovsky
no flags Details

  None (edit)
Description Lev Melnkovsky 2007-09-29 18:08:09 EDT
Description of problem:
xterm (I have tried other terminal emulators as well) window is corrupted if
another overlapping window is 

Version-Release number of selected component (if applicable):


How reproducible: Always

Steps to Reproduce: 
1. start two xterm windows
2. set color text background (like kernel menuconfig or Midninght Commander)
3. move one window by mouse overlaping another
Actual results: See screenshot
Comment 1 Lev Melnkovsky 2007-09-29 18:08:09 EDT
Created attachment 211431 [details]
terminal screenshot taken with GIMP
Comment 2 Matěj Cepl 2007-10-02 06:04:11 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Lev Melnkovsky 2007-10-02 15:29:07 EDT
Thank you very much for the response.

> Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
Unfortunatelu X11 fails to run without config and exits with

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
Comment 4 Lev Melnkovsky 2007-10-02 15:29:31 EDT
Created attachment 213871 [details]
sample xorg.conf

My real xorg.conf is longer, but the problem I described can be reproduced with
this config. The motivation of using "fbdev" rather than "radeon" driver is the
"Rotate" option. The bug, however, does not depend on "Rotate"...
Comment 5 Lev Melnkovsky 2007-10-02 15:30:56 EDT
Created attachment 213881 [details]
...and the logfile
Comment 6 Lev Melnkovsky 2007-12-22 13:17:41 EST
Any hope to have the priority raised? The bug is still there in Fedora 8 :-(
Comment 7 Ian Collier 2008-02-18 11:47:31 EST
This seems to be the same as bug 332791 and also
https://bugs.freedesktop.org/show_bug.cgi?id=12003 (which describes the problem
quite comprehensively).

I have experienced this bug on:
ATI Radeon X1300 Pro

And also on:
nVidia Quadro NVS 285

But *not* on:
ATI Radeon X1300 Pro

The freedesktop.org bug mentioned above is using the sis driver.  Therefore this
looks like a core X server bug introduced somewhere between 1.1 and 1.2.
Comment 8 Matěj Cepl 2008-02-18 18:30:42 EST
You are right. Closing as duplicate of bug 332791

*** This bug has been marked as a duplicate of 332791 ***

Note You need to log in before you can comment on or make changes to this bug.