Bug 312801 - nm-applet loses the lock icon even though VPN is still connected
nm-applet loses the lock icon even though VPN is still connected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
bzcl34nup
:
: 328751 (view as bug list)
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-09-29 20:33 EDT by Jesse Keating
Modified: 2013-01-09 21:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 22:38:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-09-29 20:33:16 EDT
At a seemingly random point after VPN is connected, the icon will lose the
little lock.  Yet the bullet for the VPN connection is still filled, and I'm
still connected to the VPN.  Obviously this shouldn't happen :)
Comment 1 Dan Williams 2007-11-01 07:04:32 EDT
*** Bug 328751 has been marked as a duplicate of this bug. ***
Comment 2 Will Woods 2007-11-05 16:25:07 EST
Is it just my imagination, or has this stopped happening? I still get dropped
from the VPN but nm-applet notices and DTRT.
Comment 3 Matěj Cepl 2007-11-06 10:02:49 EST
Still happens to me (like just now, for example).
Comment 4 Daniel Berrange 2007-11-11 14:39:04 EST
This still happens with the F8  GA packages

NetworkManager-gnome-0.7.0-0.5.svn3030.fc8
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8

The GNOME panel applet has lost the 'lock' icon, but I am still connected to the
VPN:

$ /sbin/ifconfig tun0
tun0      Link encap:UNSPEC  HWaddr
00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:10.11.14.68  P-t-P:10.11.14.68  Mask:255.255.255.0
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1412  Metric:1
          RX packets:939487 errors:0 dropped:0 overruns:0 frame:0
          TX packets:861869 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500 
          RX bytes:1185160820 (1.1 GiB)  TX bytes:50314007 (47.9 MiB)

$ ps -axuwwf | grep vpnc
root      2846  0.0  0.0   3628  1492 ?        S    10:31   0:00
/usr/bin/nm-vpnc-service
root      2857  3.9  0.0   2488  1092 ?        SL   10:31   9:38  \_
/usr/sbin/vpnc --non-inter --no-detach -


And traffic to the VPN still works. It's just the applet seems to have forgotten....
Comment 5 Bug Zapper 2008-04-04 09:57:32 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 6 Dan Williams 2008-09-29 22:38:47 EDT
pretty darn sure this doesn't happen any more

Note You need to log in before you can comment on or make changes to this bug.