Bug 312921 - Eclipse reports errors in plugin status
Eclipse reports errors in plugin status
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
: 312861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 06:35 EDT by Harald
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 14:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harald 2007-09-30 06:35:29 EDT
+++ This bug was initially created as a clone of Bug #312861 +++

Description of problem:

After a fresh installation of Eclipse, Eclipse reports a configuration error for
the component Eclipse Platform 3.2.2.r322_v20070119-CXMbUe9K_WF26uA

Version-Release number of selected component (if applicable):
The following components have been installed on a 'clean' F7 (no Eclipse was
installed before):
eclipse-gef-3.2.1-4.fc7
eclipse-emf-xsd-2.2.2-1.fc7
eclipse-subclipse-1.2.4-2.fc7
eclipse-checkstyle-4.0.1-6.fc7
eclipse-jdt-3.2.2-15.fc7
eclipse-subclipse-book-1.2.4-2.fc7
eclipse-rcp-3.2.2-15.fc7
eclipse-emf-2.2.2-1.fc7
eclipse-cdt-3.1.2-3.fc7
eclipse-pde-runtime-3.2.2-15.fc7
eclipse-ecj-3.2.2-15.fc7
eclipse-changelog-2.3.4-1.fc7
eclipse-platform-3.2.2-15.fc7
eclipse-phpeclipse-1.1.8-16.fc7

How reproducible:
Make sure no Eclipse is installed, than install the named components.
In Eclipse, open Help->Software Updates->Manage Configuration, check for the
status in the properties of "Eclipse Platform"

Steps to Reproduce:
1. install
2. Start Eclipse
3. check status of Eclipse Platform 
  
Actual results:
An error is reported
Plug-in "org.eclipse.help.webapp" version "3.2.2.R322_v20061114" referenced by
this feature is missing.

Plug-in "org.eclipse.core.filesystem.linux.x86_64" version "1.0.0.v20060603"
referenced by this feature is missing.

Plug-in "org.eclipse.update.core.linux" version "3.2.0.v20060605" referenced by
this feature is missing.

Included feature "org.eclipse.rcp_3.2.2.r322_v20070104-iwP0VLKnfFC923K" is missing.

Expected results:
Status should tell everything is ok


Additional info:

I am not sure if the error i reported as Bug #312861 is dependent from this,
also it seems to be impossible to install many tools from the WTP projects of
Eclipse, as many tools report missing festures, that seem to belong to the
Eclipse IDE itself.
Comment 1 Andrew Overholt 2007-10-01 09:41:55 EDT
*** Bug 312861 has been marked as a duplicate of this bug. ***
Comment 2 Andrew Overholt 2007-10-01 09:42:57 EDT
Can you actually not install things?  akurtov (sp?) on #fedora-java told me that
there was an issue with the product in /usr/share/eclipse/config.ini in our 3.3
series of RPMs but I'm 99% sure that 3.2.x Update Manager worked for me.  The
error reporting is due to this:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=162798
Comment 3 Harald 2007-10-01 12:49:00 EDT
Just tell what you want me to uninstall to give it a try? 
Comment 4 Andrew Overholt 2007-10-01 12:59:17 EDT
I don't expect you to be able to uninstall things since they were installed as
the root user and you should be running as a regular user.  Try installing
anything (subclipse, for example) from an update site and see if it works.  It
should (except maybe if you're running rawhide - are you?).  Thanks.
Comment 5 Harald 2007-10-01 16:57:57 EDT
I can use the Eclipse Download Manager, but i am getting messages about missing
features or plugins which i shouldn't according to the documentation 
i.e.:

Eclipse Modeling Framework (EMF) Extender SDK (2.3.1.v200709252135) requires
feature "org.eclipse.platform (3.3.0.v20061208-Fj22sCYGm0XDWm3)", or compatible.

or

"WST Server Adapters (2.0.1.v200709110637-4-0_kE77Y7TGAoAAJ) requires plug-in
"org.mortbay.jetty (5.1.11)", or compatible." when trying to install the webtools.

I initially thought it might be caused by the features marked as disabled.
Comment 6 Andrew Overholt 2007-10-01 17:03:20 EDT
So they don't install at all?  This is with rawhide, right?
Comment 7 Harald 2007-10-02 13:45:35 EDT
No i don't think i use rawhide. I used the F7 release and have the repos from
/etc/yum.repos.d/fedora-development.repo disabled. 

It is not that no plugins can be installed, for example EPIC
(http://e-p-i-c.sourceforge.net/updates/testing)did installs without trouble.

Because i was not able to install the plugins i checked the whole eclipse and
found the config errors reported.
Comment 8 Harald 2007-10-03 14:26:06 EDT
OK - i did some research on the plugin configuration, the missing
features/plugins seem to be related to the Eclipse 3.2 platform and are only
available in 3.3. 

If the config error reported are well known to you, i think we can close this bug.
Comment 9 Andrew Overholt 2007-10-03 14:59:11 EDT
Thanks, Harald.

Note You need to log in before you can comment on or make changes to this bug.