This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 31371 - can't print from kmail
can't print from kmail
Status: CLOSED DUPLICATE of bug 35937
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-10 16:22 EST by Gene Czarcinski
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-14 15:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My /etc/printcap file created by printtool (892 bytes, text/plain)
2001-04-01 14:57 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2001-03-10 16:22:32 EST
I have kmail installed but I cannot print.  The dialogs come up but nothing
happens.  Other application such as mozilla can print.  I suspect that it
is the generates postscript that is wrong.  If I "print" to a file and then
use lpr to print still nothing.

The printer is a HP4000 using the jetdirect interface.
Comment 1 Bernhard Rosenkraenzer 2001-03-16 07:28:00 EST
Works perfectly here, both printing directly to a Lexmark Color JetPrinter 
3000 and printing to a file and displaying it in kghostview.

This must be a bug in the postscript parser in your printer.
(kmail generates valid postscript, but the printer doesn't undestand it).
Comment 2 Gene Czarcinski 2001-04-01 14:56:24 EDT
OK, I believe I have a better idea what the bug is.

This is on qa0328.  The hardware is Beta Hardware system #33.  The printer is an
HP Laserjet 4000 which is connected via an HP JetDirect Ex Plus box.

I defined two print queues (both to the same IP address).  One is a jetdirect
interface (port 9100) and the other is a "Unix LPD" for queue "ram" on the ip
address.

kmail prints correctly if I use the "unix LPD" queue.  It does NOT work if I use
the jetdirect queue.

The kmail print "panel" shows the Unix LPD OK properly but not the JEtDirect
queue.  It appears that kmail (or something in qt) is interpreting things
incorrectly.

On the kmail print panel for the JetDirect queue (lp),

Printer is
lp: :sh: :ml=0: :mx=0: :sd=/var/spool/lpd/lp: :lp=

Host is
locally connected  [!!]

Comment is
Aliases and a whole bunch of stuff.

Comment 3 Gene Czarcinski 2001-04-01 14:57:51 EDT
Created attachment 14383 [details]
My /etc/printcap file created by printtool
Comment 4 Gene Czarcinski 2001-04-03 03:57:07 EDT
Still present in qa0401
Comment 5 Gene Czarcinski 2001-04-03 16:50:29 EDT
I ran another test (on qa0401) and kwite works fine -- it is only kmail that
screws up with a jetdirect (port 9100) interface.
Comment 6 Preston Brown 2001-04-04 10:03:15 EDT
that's really weird, seeing as they both use the same printing interface...
Comment 7 Gene Czarcinski 2001-04-04 16:34:04 EDT
They (kmail and kwrite) don't "look" like they use the same interface.  The
print-panel popup that comes up looks completely different.
Comment 8 Gene Czarcinski 2001-04-08 10:57:11 EDT

*** This bug has been marked as a duplicate of 35193 ***
Comment 9 Gene Czarcinski 2001-04-08 11:15:09 EDT
Oops.  It appears that the "bug" reported as 35193 is NOT the same problem.
Even with that problem resolved, kmail will still not print to a JetDirect queue
and the print panel as a wierd entry for the JetDirect queue although a Unix
Printer queue "looks" proper and prints OK.

Gene
Comment 10 Gene Czarcinski 2001-04-14 12:50:29 EDT
I believe I see what kmail is getting confused about.

The new printconf package creates an /etc/printcap file for the JetDirect
interface with an entry:

	:lp=|/usr/share/printconf/jetdirectprint:

in the definition for "lp".  For some reason, it is using the text after lp=
rather than just lp as the "name" of this print queue.

This is definitely a kmail problem.
Comment 11 Gene Czarcinski 2001-04-14 15:44:46 EDT
I have looked at the source code and this is NOT a kmail bug.  Kmail appears to
be one of the few (only?) application which uses qt's QPrint function.  The
problem is in the parsePrintcap function located in qprintdialog.cpp.  Their
"simplistic" parsing of /etc/printcap treats the qhole string of characters
(minus whitespace) between the beginning of a definition and the first '|'
character to be the "name" of the print queue.

Circumvention: assign an alias to the print queue.

*** This bug has been marked as a duplicate of 35937 ***

Note You need to log in before you can comment on or make changes to this bug.