Bug 35193 - JetDirect 9100 print errors
JetDirect 9100 print errors
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 35194 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-08 10:53 EDT by Gene Czarcinski
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 13:46:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/printcap with JetDirect and Unix Printer queues. (892 bytes, text/plain)
2001-04-08 10:54 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2001-04-08 10:53:59 EDT
This applies to qa0404.

I originally files this bug report against kmail but have since found that
some software of mine as well as a2ps have the same problem.

My hardware is the HP JETDIRECT EX Plus box connected to an HP 4000.

When I saw that the new RedHat printconf package supported the JetDirect
interface (port 9100), I decided to use that (I previously used the ifhp
filter with JetDirect successfully).  Now the JetDirect box can also be
configured as a Unix Printer (lpd queue).

The problem is that postscript output to the printer will terminate before
printing the entire file.  If you print a short file, then nothing is
printed although something is sent to the printer.

I can get behavior with kmail, kwrite, and a2ps but not (strangely) with
either netscape or mozilla.

When using a2ps to print a README file which generates "8 pages on 4
sheets", I get the first two sheets formated properly, then the printer
seems to pause (delay a tenth of s second) and switch modes.  A single
sheet is printed with what appears to be a single line of text surrounded
by parens (postscript).  Finally, a blank sheet is "printed".

I experimented and created another queue (lp1).  This time I defined the
JEetDirect interface as a "Unix Printer" with the ip address and the queue
defined as "raw".  When I use this second queue with a2ps, kmail, kwrite,
etc. everything works!!

Since the printconf package includes the filters, etc. for printing files,
it appears that there is a bug.  Based on my experience, it is highly
repeatable.

I will attach my printcap.

Gene
Comment 1 Gene Czarcinski 2001-04-08 10:54:59 EDT
Created attachment 14924 [details]
/etc/printcap with JetDirect and Unix Printer queues.
Comment 2 Gene Czarcinski 2001-04-08 10:57:06 EDT
*** Bug 31371 has been marked as a duplicate of this bug. ***
Comment 3 Gene Czarcinski 2001-04-08 11:12:21 EDT
mumble, mumble.  I found the "problem".  I had the "send eot" checked in printtool.

Unchecking this and stuff printed properly (except kmail which is still screwed
up).  I will "unmark" 31371 as being a dup since it still can't handle jetdirect
definitions.

I am NOT going to mark this as resolved since there needs to be some warning or
documentation about using "send eot".  In previous versions of RedHat printer
configuration, I always used "send eot" and this became a habit.  Using this
apparently causes the printer to abort its current job with the current suite of
software (LPRng and printconf).
Comment 4 Bill Nottingham 2001-04-08 23:51:53 EDT
*** Bug 35194 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2002-01-10 11:02:25 EST
Presumably 'sent EOT' is still broken in 7.2?
Comment 6 Gene Czarcinski 2003-10-27 13:46:02 EST
OBE now I am sure

Note You need to log in before you can comment on or make changes to this bug.