Bug 313981 - gnome-password-generator requires redhat-artwork
gnome-password-generator requires redhat-artwork
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-password-generator (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ArtworkSplit
  Show dependency treegraph
 
Reported: 2007-10-01 11:16 EDT by Ray Strode [halfline]
Modified: 2007-12-10 15:44 EST (History)
0 users

See Also:
Fixed In Version: 1.5-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 15:44:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2007-10-01 11:16:10 EDT
Hi,

I'm trying to get rid of redhat-artwork (see bug 305441).  

Do you know what gnome-password-generator needs redhat-artwork for?

Could you change the requires to one or more of:

bluecurve-classic-metacity-theme
bluecurve-gdm-theme
bluecurve-gnome-theme
bluecurve-gtk-themes
bluecurve-icon-theme
bluecurve-metacity-theme
bluecurve-xmms-skin
fedorabubbles-gdm-theme
fedoradna-gdm-theme
fedoraflyinghigh-gdm-theme
fedora-gnome-theme
fedora-icon-theme
gtk-bluecurve-engine

?
Comment 1 Debarshi Ray 2007-10-02 16:18:45 EDT
It uses redhat-artwork for the following portion of the code:

   102          menu_items = (
   103              ("/_File", None, None, 0, "<Branch>"),
   104              ("/File/_Quit", "<control>Q", self.DestroyCallback, 0,
"<StockItem>", gtk.STOCK_QUIT),
   105              ("/_Help", None, None, 0, "<Branch>"),
   106              ("/_Help/_About", None, self.AboutCallback, 0,
"<StockItem>", "gnome-stock-about")
   107          )

Reference:
https://bugzilla.redhat.com/show_bug.cgi?id=245649

As far as I understand, redhat-artwork should be replaced by either
fedora-gnome-theme or fedora-icon-theme. Which one should I pick?
Comment 2 Ray Strode [halfline] 2007-10-02 16:50:12 EDT
i'd just use gtk.STOCK_ABOUT there and drop the dep entirely (eventually you may
want to port to UI manager btw)
Comment 3 Ray Strode [halfline] 2007-10-02 16:51:15 EDT
so just to be clear, I'd drop the Requires: redhat-artwork from the spec file
and change the occurrence of "gnome-stock-about" to gtk.STOCK_ABOUT
Comment 4 Debarshi Ray 2007-10-03 02:57:54 EDT
Sure. I will update the package after pointing upstream to this issue.
Comment 5 Debarshi Ray 2007-10-06 09:07:57 EDT
This should be fixed in devel now. I am requesting a push to updates-testing for
F-7.

Please confirm so that this bug can be closed.
Comment 6 Ray Strode [halfline] 2007-10-09 11:03:56 EDT
confirmed, Requires: redhat-artwork is no longer in rawhide.

We don't really need to update F-7.  It's not going to be changed
Comment 7 Fedora Update System 2007-10-11 18:52:22 EDT
gnome-password-generator-1.5-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-password-generator'
Comment 8 Fedora Update System 2007-12-10 15:44:29 EST
gnome-password-generator-1.5-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.