Bug 314 - status function returns erroneous results
status function returns erroneous results
Status: CLOSED DUPLICATE of bug 281
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
5.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-05 23:06 EST by Adam Thompson
Modified: 2014-03-16 22:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-06 15:52:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Thompson 1998-12-05 23:06:09 EST
the status() function in /etc/rc.d/init.d/functions
returns consistently erroneous results -- it always
indicates that the process in question is running.
This is due to a bug in the function - lines 129 through
134 duplicate functionality already contained in
pidofproc() at line 113, only incorrectly.  The grep
stage of the pipe picks up itself.  grep is started before
ps finishes executing - so something is always found - the
grep command itself!  Removing lines 129 through 134 causes
the behaviour to be correct again.  This could cause problems, as "subsystem dead but locked" will NEVER be returned as a status now - some things depend on that return value for correct functioning.  Typically, watchdog-type scripts break under this buggy behaviour.
Comment 1 Adam Thompson 1998-12-06 00:43:59 EST
just reviewed RedHat's "Priority" levels -- this should be a "Normal"
severity, not "High", bug.  While it can cause disruption of service
(in the case where a watchdog relies upon the "status" function to
indicate a dead service), it does not cause system crashes or data
corruption.  Sorry for the inconvenience.
Comment 2 David Lawrence 1998-12-06 15:40:59 EST
Have you been able to get any past installs to work from the tree you
have set up from different workstations?
Comment 3 David Lawrence 1998-12-06 15:41:59 EST
Disregard last comment by me. I entered it on the wrong bug report.
Comment 4 Bill Nottingham 1998-12-06 15:52:59 EST
*** This bug has been marked as a duplicate of 281 ***

Note You need to log in before you can comment on or make changes to this bug.