Bug 314541 - dangling symlink for veth2
dangling symlink for veth2
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 15:14 EDT by Scott Scriven
Modified: 2009-12-14 16:25 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 07:55:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport -a (.tar.bz2) (474.52 KB, application/octet-stream)
2007-10-01 15:14 EDT, Scott Scriven
no flags Details

  None (edit)
Description Scott Scriven 2007-10-01 15:14:33 EDT
Description of problem:
This link is broken:
/dev/.udev/failed/class@net@veth2 -> /sys/class/net/veth2

The link is not necessarily the main issue, since veth2 does not exist.  
However, the system has veth0, veth1, veth3.  I'm unsure why veth2 is missing.

I haven't noticed any functional issues with this setup, but the missing veth2 
is somewhat worrisome.


Version-Release number of selected component (if applicable):
RHEL5.1 beta s8 (kernel 2.6.18-48.el5xen)


How reproducible: 1/1


Steps to Reproduce:
1. Install RHEL5.1 beta s8, with Xen / install key, default settings.
2. (unsure if intermediate steps are applicable)
3. Check for dangling symlinks in /dev/.udev/
  
Actual results: veth2 symlink points at nonexistent /sys entry


Expected results: /sys entry should exist, but in case it does not, the symlink 
should not exist either.

Additional info:
I created a paravirtual guest before I noticed the missing veth2.  I also 
replaced "-- rhgb quiet" with "dom0_mem=4G -- debug" in elilo.conf.  I'm not yet 
sure if either of these are relevant.
Comment 1 Scott Scriven 2007-10-01 15:14:33 EDT
Created attachment 212701 [details]
sysreport -a (.tar.bz2)
Comment 2 Scott Scriven 2007-10-09 18:08:49 EDT
I encountered this today using release candidate 1.  The missing veth device was 
veth0, but everything else appeared to be the same.
Comment 3 Scott Scriven 2008-04-08 15:58:59 EDT
FWIW, this is still present in RHEL5.2 beta 3.  After a default install with
Xen, I ended up with no veth0.

It doesn't appear to have any functional impact, though.  At least, not that
I've noticed.  Is it intended behavior?
Comment 4 Daniel Berrange 2008-07-09 07:55:57 EDT
This is an artifact of the way Xen's networking works.

When you initially boot there is just the real physical device 'eth0'

Then Xen runs and loads its netloop module. This creates veth0 -> veth3 and
vif0.0 -> vif0.3


Then Xen's network-bridge script runs. This renames 'eth0' to 'peth0'. Adds
'peth0' and 'vif0.0' to a bridge 'xenbr0'. The 'veth0' is then renamed to 'eth0'.

This last step causes the dangling symlink and is harmless

Note You need to log in before you can comment on or make changes to this bug.