Bug 31494 - RFE: Make lba32 option more easily available
RFE: Make lba32 option more easily available
Status: CLOSED DUPLICATE of bug 14351
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2001-03-12 08:25 EST by whampton
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-11 16:15:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description whampton 2001-03-12 08:25:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.19pre9 i686)

/dev/hda1 is 1G, Windows 98, fat32.  I am trying to install Wolverine
following this.
DiskDruid displayed warnings and errors about not being able to make a boot
partition >cyl. 1024.  The Next> prompt never appeared.  I had to go back
and use fdisk.

Reproducible: Always
Steps to Reproduce:
1.  load Windows 98 on a 1G C: drive, /dev/hda
2.  try to load Wolverine, use Disk Druid
3.  specify / or /boot, error appears

Actual Results:  I got the warning message and DiskDruid would not allow me
to write the partition then

Expected Results:  A warning would appear, like that when using FDISK, but
I could continue installing LInux, provided the BIOS allowed me to have a
bootable partition >cyl 1024.

Computer:  Toshiba T8000 laptop, 10G HD, 128M RAM, Neomagic chipset
Windows 98 in a 1G DOS FAT32 partition, /dev/hda1.  
Fdisk used successfully and computer properly boots to graphical Lilo with 
options for DOS (windows) and Linux.  

Note, when using fdisk with the graphical installer, the text for fdisk
kept wrapping, making it difficult to use.  The problem was the scrollable
help/banner on the left
side of the screen.  Suggest:  either shorten messages on fdisk, or do
something with the banner.  It really looks ugly.
Comment 1 Michael Fulbright 2001-03-12 11:08:42 EST
Because of the unreliability we found in accurately detecting (automatically)
whether a board would support > 1024 cylinder booting or not, we made it so we
allow users of fdisk (who generally are more technically inclined) to make this
designation, but disk druid (more newbies) users do not.

Next release we will make this all much more clear to both advanced and new users.
Comment 2 whampton 2001-03-12 12:32:18 EST
For the 7.1 release, you might want to at least make a change to the text in the
popup window and/or the text on the left side of the screen....
Comment 3 Michael Fulbright 2001-04-11 16:16:07 EDT

*** This bug has been marked as a duplicate of 14351 ***

Note You need to log in before you can comment on or make changes to this bug.