Bug 315021 - Update translate-toolkit to the latest release 1.0.1
Update translate-toolkit to the latest release 1.0.1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: translate-toolkit (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: i18n
: 427611 (view as bug list)
Depends On:
Blocks: 430887
  Show dependency treegraph
 
Reported: 2007-10-02 01:17 EDT by Dwayne Bailey
Modified: 2008-02-13 03:42 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.0.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 00:19:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated spec file for 1.0.1 (3.51 KB, patch)
2007-12-19 08:17 EST, Dwayne Bailey
no flags Details | Diff
Updated patch for ElementTree dependency (516 bytes, patch)
2007-12-19 08:19 EST, Dwayne Bailey
no flags Details | Diff
1.0.1-2 Add the ability to create manpages (4.20 KB, patch)
2007-12-20 06:31 EST, Dwayne Bailey
no flags Details | Diff
1.0.1-4 Remove python-Levenshtein dependency (933 bytes, patch)
2008-02-05 04:47 EST, Dwayne Bailey
no flags Details | Diff

  None (edit)
Description Dwayne Bailey 2007-10-02 01:17:19 EDT
Description of problem:
Upgrade to the latest release of the Translate Toolkit

Version-Release number of selected component (if applicable):
0.10.1

How reproducible:
moz2po --version

Expected results:
moz2po 1.0.1

Additional info:
Version 1.0.1 of the toolkit adds quite a number of features.  0.10.1 is now
quite old as there have been 0.11, 1.0 and 1.0.1 releases.
For important changes see
http://translate.sourceforge.net/wiki/toolkit/important_changes#1.0.1
Comment 1 Dwayne Bailey 2007-12-19 08:17:53 EST
Created attachment 290012 [details]
Updated spec file for 1.0.1

Updates to 1.0.1 release.  Fix up how we install documentation.
Comment 2 Dwayne Bailey 2007-12-19 08:19:00 EST
Created attachment 290013 [details]
Updated patch for ElementTree dependency

Updates the existing 0.10.1 patch to the same as in Subversion.
Comment 3 Dwayne Bailey 2007-12-20 06:31:32 EST
Created attachment 290144 [details]
1.0.1-2 Add the ability to create manpages

The spec file will now also generate manpages for the various tools.
Comment 4 Jens Petersen 2008-01-09 00:49:29 EST
ping?
Comment 5 Jens Petersen 2008-01-20 21:25:30 EST
Thanks for the patches, Dwayne!

I updated devel to 1.0.1 with them.
It would be good to do an update soon for F8 too.
Comment 6 Dwayne Bailey 2008-01-21 06:37:40 EST
Thanks Jens,

Is there anything I can help with/need to do in terms of getting the F8 update
through?
Comment 7 Mamoru TASAKA 2008-01-21 13:26:21 EST
*** Bug 427611 has been marked as a duplicate of this bug. ***
Comment 8 Jens Petersen 2008-01-21 19:42:46 EST
Asking Caius to help backport the update to F8.

(In reply to comment #6)
> Is there anything I can help with/need to do in terms of getting the F8 update
> through?

Well, Dwayne, you could sanity check the changes for F8 and help test
the package when it lands in the testing repo. :)
Comment 9 Jens Petersen 2008-01-22 23:13:11 EST
BTW, could you please explain about

Requires:       python-Levenshtein
Requires:       python-psyco

you added in your patch?  Does psyco give a big increase in performance?
(I don't see python-Levenshtein in fedora, but maybe it is in koji?)
Comment 10 Jens Petersen 2008-01-22 23:36:49 EST
Built translate-toolkit-1.0.1-1.fc8 and pushed to bodhi.
Comment 11 Dwayne Bailey 2008-01-23 03:17:22 EST
(In reply to comment #9)
> BTW, could you please explain about
> 
> Requires:       python-Levenshtein
> Requires:       python-psyco
> 
> you added in your patch?  Does psyco give a big increase in performance?
> (I don't see python-Levenshtein in fedora, but maybe it is in koji?)

Re: python-Levenshtein
You are correct this isn't in Fedora, my bad for not checking more carefully. 
The toolkit will fallback to using a Python version which is much slower if
python-Levenshtein is missing.  I'll have to look at building an RPM separately
for that.  So this dependency can be safely removed for now.

The site that originally hosted it seems to be gone:
http://trific.ath.cx/python/levenshtein/
but I have the 0.10.1 source on my computer. And here are other RPM builds:

http://rpm.pbone.net/index.php3/stat/4/idpl/4454315/com/python-Levenshtein-0.10-0.1.i486.rpm.html


Re: Psyco
These are the outputs from the 3rd of 3 runs first without and then without psyco.

[dwayne@dhcppc32 convert]$ time -p oo2po --psyco=none -P en-US-stable.sdf ooslow
processing 246 files...
[###########################################] 100%
real 211.97
user 203.46
sys 3.35

[dwayne@dhcppc32 convert]$ time -p oo2po --psyco=full -P en-US-stable.sdf oofast
processing 246 files...
[###########################################] 100%
real 235.11
user 140.85
sys 5.72

So yes it does make a substantial difference.  Without it the conversion from
OpenOffice.org SDF to PO takes 3:20 and with it it takes 2:20.  Shaving off a
minute of execution time.
Comment 12 Dwayne Bailey 2008-01-24 03:23:28 EST
(In reply to comment #9)
> Requires:       python-Levenshtein

Bug 429882 is for packaging the C based Levenshtein functionality.
Comment 13 Fedora Update System 2008-01-24 16:46:21 EST
translate-toolkit-1.0.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update translate-toolkit'
Comment 14 Caius Chance 2008-01-24 19:12:38 EST
We could create another bug for requiring python-Levenshtein in
translate-toolkit. The bug will depend on bug#429882 and be processed right
after such bug.
Comment 15 Jens Petersen 2008-01-24 19:17:55 EST
(In reply to comment #14)
> We could create another bug for requiring python-Levenshtein in
> translate-toolkit. The bug will depend on bug#429882 and be processed right
> after such bug.

Good suggestion, and we could add the python-psyco dep to devel now I guess.
Comment 16 Dwayne Bailey 2008-02-01 09:32:12 EST
(In reply to comment #15)
> (In reply to comment #14)
> > We could create another bug for requiring python-Levenshtein in
> > translate-toolkit. The bug will depend on bug#429882 and be processed right
> > after such bug.
> 
> Good suggestion, and we could add the python-psyco dep to devel now I guess.

Bug 430887 is such a bug and its blocked by this one and the packaging of
python-Levenshtein.

I've been running with the Fedora version for a few days and all seems to be
working correctly.

Comment 17 Fedora Update System 2008-02-02 04:00:30 EST
translate-toolkit-1.0.1-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update translate-toolkit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1294
Comment 18 Dwayne Bailey 2008-02-05 04:47:46 EST
Created attachment 293986 [details]
1.0.1-4 Remove python-Levenshtein dependency

I tested the current 1.0.1-3 build in a clean environment, i.e. all required
pacakages removed.  This fails as 1.0.1-3 still requires python-Levenshtein.

The patch removes the requirements, updates the release number and changelog.
Comment 19 Jens Petersen 2008-02-05 20:36:30 EST
translate-toolkit-1.0.1-1.fc8 was the package that was supposed to be tested
and pushed.  I requested it be pushed to stable now anyway.
Comment 20 Fedora Update System 2008-02-13 00:19:32 EST
translate-toolkit-1.0.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Dwayne Bailey 2008-02-13 03:42:35 EST
Thanks to everyone for the help on this bug and apologies for my confusion
around 1.0.1-1 vs 1.0.1-3.

Note You need to log in before you can comment on or make changes to this bug.