Bug 430887 - Add dependency on python-Levenshtein
Add dependency on python-Levenshtein
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: translate-toolkit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dwayne Bailey
Fedora Extras Quality Assurance
: Reopened
Depends On: 315021 python-Levenshtein
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 08:06 EST by Dwayne Bailey
Modified: 2008-11-24 02:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-22 11:48:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dwayne Bailey 2008-01-30 08:06:18 EST
Description of problem:
The current translate-toolkit uses a slow python based levenshtein distance
algorithm to compute text matches.  It can use a C based implementation if it is
available.

Version-Release number of selected component (if applicable):
1.0.1 (not yet in Fedora)

Additional info:
This bug depends on the packaging of python-Levenshtein and is here to catch
when that happens so that the translate-toolkit can be changed to include that
as a dependency and thus enjoy much faster text matching.
Comment 1 Dwayne Bailey 2008-03-27 05:29:34 EDT
Bug 439140 is for packaging Translate Toolkit 1.1.1, it has the same
python-Levenshtein issue.  We should fix it as part of that, so closing as WONTFIX
Comment 2 Jens Petersen 2008-11-12 18:43:45 EST
Reopening since python-Levenshtein is now in Fedora.
Comment 3 Fedora Update System 2008-11-13 06:42:14 EST
translate-toolkit-1.2.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/translate-toolkit-1.2.0-1.fc9
Comment 4 Fedora Update System 2008-11-13 13:24:02 EST
translate-toolkit-1.2.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/translate-toolkit-1.2.0-1.fc10
Comment 5 Fedora Update System 2008-11-14 07:53:37 EST
translate-toolkit-1.2.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update translate-toolkit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9677
Comment 6 Fedora Update System 2008-11-17 04:37:00 EST
translate-toolkit-1.2.0-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/translate-toolkit-1.2.0-3.fc10
Comment 7 Fedora Update System 2008-11-19 09:45:42 EST
translate-toolkit-1.2.0-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update translate-toolkit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9693
Comment 8 Fedora Update System 2008-11-22 11:48:06 EST
translate-toolkit-1.2.0-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-11-22 11:58:51 EST
translate-toolkit-1.2.0-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Jens Petersen 2008-11-24 02:14:37 EST
You need to push python-Levenshtein to updates too with bodhi for f10.

Note You need to log in before you can comment on or make changes to this bug.