Bug 315111 - Missing dependency for compat-libstdc++-33
Missing dependency for compat-libstdc++-33
Status: CLOSED DUPLICATE of bug 429339
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 04:40 EDT by Holger Urbanek
Modified: 2008-02-28 09:37 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 09:37:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Holger Urbanek 2007-10-02 04:40:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
I installed thunderbird via 'yum install thunderbird' and experienced segfaults wehen looking at specific mails.
Strace revealed that it was looking for libstdc++.so.5 wich is provided by the compat-libstdc++-33 package, yet not installed by yum automatically. Once installed, segfaults disappeared.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1. Make a clean fedora 7 -install (german)
2. copied my old FC6-Home (don't know if necessary)
3. yum install thunderbird
4. try to look at your mails (not all, for me, however, about 1/3 of all produced a segfault, e.g. a mail from xing.com ad the spam-report from gmx.de)

Actual Results:
Thunderbird segfaults when viewing some mails

Expected Results:
It shouldn't segfault. (funny field ;-))

Additional info:

Last lines from the 'strace thunderbird':
gettimeofday({1191311970, 463517}, NULL) = 0
futex(0xb293530, FUTEX_WAKE_OP, 1, 1, 0xb29352c, {FUTEX_OP_SET, 0, FUTEX_OP_CMP_EQ, 0}) = 1
futex(0xa2706f0, FUTEX_WAKE, 1)         = 1
futex(0xb357ee4, FUTEX_WAKE, 1)         = 1
futex(0xb357ee8, FUTEX_WAIT, 1, NULL)   = -1 EAGAIN (Resource temporarily unavailable)
futex(0xa2706f0, FUTEX_WAKE, 1)         = 0
write(6, "\372", 1)                     = 1
write(3, "\1\30\r\0\2\16`\4\334\r`\4\0\0\0\0\1\0\1\0\0\0\1\0#\0\0\0\32(\0\0"..., 240) = 240
ioctl(3, FIONREAD, [0])                 = 0
poll([{fd=3, events=POLLIN}, {fd=10, events=POLLIN}, {fd=14, events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=17, events=POLLIN|POLLPRI}, {fd=18, events=POLLIN|POLLPRI}], 6, 0) = 0
ioctl(3, FIONREAD, [0])                 = 0
poll([{fd=3, events=POLLIN}, {fd=10, events=POLLIN}, {fd=14, events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=17, events=POLLIN|POLLPRI}, {fd=18, events=POLLIN|POLLPRI}, {fd=5, events=POLLIN, revents=POLLIN}], 7, -1) = 1
gettimeofday({1191311970, 464608}, NULL) = 0
open("/usr/share/fonts/dejavu-lgc/DejaVuLGCSerif-Bold.ttf", O_RDONLY) = 42
fcntl64(42, F_SETFD, FD_CLOEXEC)        = 0
fstat64(42, {st_mode=S_IFREG|0644, st_size=203224, ...}) = 0
mmap2(NULL, 203224, PROT_READ, MAP_PRIVATE, 42, 0) = 0xb0c3d000
close(42)                               = 0
brk(0xb462000)                          = 0xb462000
brk(0xb48e000)                          = 0xb48e000
brk(0xb4af000)                          = 0xb4af000
gettimeofday({1191311970, 526165}, NULL) = 0
futex(0xb293530, FUTEX_WAKE_OP, 1, 1, 0xb29352c, {FUTEX_OP_SET, 0, FUTEX_OP_CMP_EQ, 0}) = 1
futex(0xa90a2c0, FUTEX_WAKE, 1)         = 1
futex(0xa3c5b2c, FUTEX_WAKE, 1)         = 1
futex(0xa3c5b30, FUTEX_WAIT, 1, NULL)   = -1 EAGAIN (Resource temporarily unavailable)
futex(0xa90a2c0, FUTEX_WAKE, 1)         = 0
write(6, "\372", 1)                     = 1
write(3, "\f\30\7\0\2\16`\4\17\0`\4\0\0\0\0\0\0\0\0\376\3\0\0*\2\0\0\f(\7\0"..., 56) = 56
ioctl(3, FIONREAD, [128])               = 0
read(3, "\26\300\365\266\3\16`\4\3\16`\4\0\0\0\0\0\0\0\0\r\4*\2\0\0\0\n\3\16`\4"..., 128) = 128
poll([{fd=3, events=POLLIN}, {fd=10, events=POLLIN}, {fd=14, events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=17, events=POLLIN|POLLPRI}, {fd=18, events=POLLIN|POLLPRI}], 6, 0) = 0
poll([{fd=3, events=POLLIN}, {fd=10, events=POLLIN}, {fd=14, events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=17, events=POLLIN|POLLPRI}, {fd=18, events=POLLIN|POLLPRI}], 6, 0) = 0
ioctl(3, FIONREAD, [0])                 = 0
poll([{fd=3, events=POLLIN}, {fd=10, events=POLLIN}, {fd=14, events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=17, events=POLLIN|POLLPRI}, {fd=18, events=POLLIN|POLLPRI}, {fd=5, events=POLLIN, revents=POLLIN}], 7, -1) = 1
futex(0x9efc380, FUTEX_WAKE_OP, 1, 1, 0x9efc37c, {FUTEX_OP_SET, 0, FUTEX_OP_CMP_EQ, 0}) = 1
open("/home/urbanek/.thunderbird/f1h8n6k4.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libstoragecomps.so", O_RDONLY) = 42
read(42, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\314?\0\0004\0\0\0"..., 512) = 512
fstat64(42, {st_mode=S_IFREG|0775, st_size=1881645, ...}) = 0
mmap2(NULL, 317920, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 42, 0) = 0x279e000
mmap2(0x27ea000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 42, 0x4b) = 0x27ea000
close(42)                               = 0
open("/usr/lib/thunderbird-2.0.0.5/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/local/lib/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
open("tls/i686/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
open("tls/i686/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
open("tls/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
open("tls/libstdc++.so.5", O_RDONLY)    = -1 ENOENT (No such file or directory)
open("i686/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
open("i686/libstdc++.so.5", O_RDONLY)   = -1 ENOENT (No such file or directory)
open("sse2/libstdc++.so.5", O_RDONLY)   = -1 ENOENT (No such file or directory)
open("libstdc++.so.5", O_RDONLY)        = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 42
fstat64(42, {st_mode=S_IFREG|0644, st_size=53731, ...}) = 0
mmap2(NULL, 53731, PROT_READ, MAP_PRIVATE, 42, 0) = 0xb0c2f000
close(42)                               = 0
open("/lib/tls/i686/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/i686/sse2", 0xbfdc84cc) = -1 ENOENT (No such file or directory)
open("/lib/tls/i686/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/i686", 0xbfdc84cc)     = -1 ENOENT (No such file or directory)
open("/lib/tls/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/sse2", 0xbfdc84cc)     = -1 ENOENT (No such file or directory)
open("/lib/tls/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/lib/i686/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/i686/sse2", 0xbfdc84cc)    = -1 ENOENT (No such file or directory)
open("/lib/i686/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/i686", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/lib/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/sse2", 0xbfdc84cc)         = -1 ENOENT (No such file or directory)
open("/lib/libstdc++.so.5", O_RDONLY)   = -1 ENOENT (No such file or directory)
stat64("/lib", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/tls/i686/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/tls/i686/sse2", 0xbfdc84cc) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/i686/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/tls/i686", 0xbfdc84cc) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/tls/sse2", 0xbfdc84cc) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/tls", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/i686/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/i686/sse2", 0xbfdc84cc) = -1 ENOENT (No such file or directory)
open("/usr/lib/i686/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/i686", 0xbfdc84cc)     = -1 ENOENT (No such file or directory)
open("/usr/lib/sse2/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/sse2", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/libstdc++.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/usr/lib", {st_mode=S_IFDIR|0755, st_size=57344, ...}) = 0
munmap(0xb0c2f000, 53731)               = 0
munmap(0x279e000, 317920)               = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
unlink("/home/urbanek/.thunderbird/f1h8n6k4.default/lock") = 0
rt_sigaction(SIGSEGV, {SIG_DFL}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [SEGV], NULL, 8) = 0
tgkill(4153, 4153, SIGSEGV)             = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Comment 1 Christopher Aillon 2007-10-03 11:15:42 EDT
My guess is that there is a specific extension/plugin you have installed which
requires libstdc++33.  Thunderbird itself does not.
Comment 2 Holger Urbanek 2007-10-04 03:22:19 EDT
My installed plugins are:
Enigmail 0.95.3
Lightning 0.5
Comment 3 Matěj Cepl 2008-02-28 09:37:45 EST

*** This bug has been marked as a duplicate of 429339 ***

Note You need to log in before you can comment on or make changes to this bug.