Bug 315121 - Within Anaconda it sould be possible to change the install-mirror
Within Anaconda it sould be possible to change the install-mirror
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 301901 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 04:53 EDT by Holger Urbanek
Modified: 2008-01-22 14:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 14:43:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Holger Urbanek 2007-10-02 04:53:51 EDT
Description of problem:

If you try to do a network-update from the minimal-boot-cd, and your chosen
(ftp) mirror is under heavy load, it quite often happens, that anaconda is not
able to fetch a needed package.
Anaconda then suggests, that you "sould coose a different mirror", however only
the two buttons: "reboot" and "retry" are presented. 
If you are REALLY patient, "retry" will get you through the installation process ;-)
Reboot is specifically warned upon, since it leaves you with an halfupdated system.
So, another button like "Choose Mirror" would really be handsome.


Version-Release number of selected component (if applicable):
Anaconda that ships with F7 minimal-boot cd

How reproducible:
Always


Steps to Reproduce:
1. Do an network-update from FC6 to F7
2. choose a mirror with high load (e.g. the official fedora source ;-) )
3. start away
  
Actual results:
Inconvenient loss of an huge amount of time

Expected results:
Conveniant installation procedure
Comment 1 Chris Lumens 2007-12-18 13:56:38 EST
I am working on this sort of thing right now for F9.  Stay tuned.
Comment 2 Chris Lumens 2007-12-18 14:32:36 EST
*** Bug 301901 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2008-01-22 14:43:08 EST
This code is now in Rawhide.  Please try it out and let me know if it's working
well for you.  I expect there to still be some bugs.  If so, please open a new
bug report on the specific problem.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.