Bug 315181 - whole system pauses for approx. 1 second when running chrony
whole system pauses for approx. 1 second when running chrony
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 05:29 EDT by Mike Fleetwood
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.9-61.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 17:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Fleetwood 2007-10-02 05:29:21 EDT
The whole system pauses for approximately 1 second every few minutes.
The kernel thread events/0 consumes 100% of the CPU preventing any other
task from being scheduled for approximately 1 second.  This started after
updating from kernel 2.6.20-1.2962.fc6.i686 to 2.6.22.2-42.fc6.i686.  This
only occurs when running chrony (http://chrony.sunsite.dk/) to synchronise
time.  (Chrony monitors and adjusts the hardware RTC as well as the kernel
software clock).  Each pause is triggered every few minutes when chrony
accesses the RTC clock.


Version-Release number of selected component (if applicable):
Kernel 2.6.22.x
(Confirmed with kernel 2.6.22.2-42.fc6.i686, 2.6.22.4-45.fc6 and
2.6.22.7-57.fc6).


How reproducible:
Always.


Steps to Reproduce:
1. Boot kernel 2.6.22.x-*.fc6
2. Run chrony


Actual results:
Whole OS pauses for approximately 1 second every few minutes.


Expected results:
No OS pauses.


Additional info:
This was caused by switching the kernel configuration from the old PC
compatible RTC driver to the new portable RTC class drivers.
diff -y /boot/config-2.6.20-1.2962.fc6 /boot/config-2.6.22.1-22.fc6
...
CONFIG_RTC=y           | # CONFIG_RTC is not set
                       > CONFIG_GEN_RTC=y
                       > CONFIG_GEN_RTC_X=y

My investigation is detailed in this email to the fedora-list.
https://www.redhat.com/archives/fedora-list/2007-September/msg01099.html

This is also a known bug in the Debian bug tracking system.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=294030

The RTC driver configuration change is reversed in Fedora 7 kernel
2.6.22.9-91.fc7.  Fragment from the update notification:
 Additional fixes:
 Revert to the old RTC driver (#265721, #284191)

These other Red Hat bugzilla bugs are reported as to be fixed by reverting
the configuration change to use the old PC compatible RTC driver again and
is due for release in kernel 2.6.22.9-61.fc6.
https://bugzilla.redhat.com/show_bug.cgi?id=265721
https://bugzilla.redhat.com/show_bug.cgi?id=284191

I expect that this bug will be resolved by the same fix.
Comment 1 Chuck Ebbert 2007-10-02 17:51:58 EDT
Should be fixed in -61. Test kernels are at
http://people.redhat.com/cebbert/kernels/FC6/
If you know how to install them manually you can test.
Comment 2 Mike Fleetwood 2007-10-02 19:17:08 EDT
Thanks Chuck,

The test kernel fixes my bug.  No more pauses.

Mike

Note You need to log in before you can comment on or make changes to this bug.