Bug 315261 - libutempter requires applications to have setgid utempter
libutempter requires applications to have setgid utempter
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libutempter (Show other bugs)
5.1
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
desktop-bugs@redhat.com
: Reopened
Depends On: 246063
Blocks: 309691
  Show dependency treegraph
 
Reported: 2007-10-02 07:14 EDT by Miroslav Lichvar
Modified: 2013-04-12 15:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 06:48:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miroslav Lichvar 2007-10-02 07:14:03 EDT
+++ This bug was initially created as a clone of Bug #246063 +++

Description of problem:
Since FC6 the utemper binary is hidden in /usr/libexec/utempter and applications
using libutempter are required to have setgid utempter. This is causing problems
as the applications have removed some environment variables like LD_LIBRARY_PATH
and TMPDIR (see bug #229360).

Please move the utempter binary back to /usr/sbin and drop utempter group, or
change permissions of the directory to 755.
Comment 1 Søren Sandmann Pedersen 2008-01-04 16:10:34 EST
Andreas has fixed/is fixing this in Fedora - to get things changed in RHEL,
we'll need a bug that goes through issue tracker.

Comment 2 Radek Vokal 2008-01-07 07:25:02 EST
This bug blocks xterm update. Please don't close it. 
Comment 3 Denise Dumas 2008-01-31 14:29:53 EST
This problem is blocking 309691, which we would like to fix on the 5.3 Fasttrack. 
This also needs to move to 5.3 Fasttrack.
Comment 9 errata-xmlrpc 2008-08-06 06:48:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0652.html

Note You need to log in before you can comment on or make changes to this bug.