Bug 246063 - libutempter requires applications to have setgid utempter
Summary: libutempter requires applications to have setgid utempter
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libutempter   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 229360 235972 315261
TreeView+ depends on / blocked
 
Reported: 2007-06-28 09:16 UTC by Miroslav Lichvar
Modified: 2014-06-18 09:09 UTC (History)
6 users (show)

Fixed In Version: 1.1.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 22:19:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miroslav Lichvar 2007-06-28 09:16:11 UTC
Description of problem:
Since FC6 the utemper binary is hidden in /usr/libexec/utempter and applications
using libutempter are required to have setgid utempter. This is causing problems
as the applications have removed some environment variables like LD_LIBRARY_PATH
and TMPDIR (see bug #229360).

Please move the utempter binary back to /usr/sbin and drop utempter group, or
change permissions of the directory to 755.

Version-Release number of selected component (if applicable):
libutempter-1.1.4-3.fc6

Comment 1 Rex Dieter 2007-06-28 12:25:02 UTC
kdebase's konsole has similar issues as xterm (env variables removed due to this).  

Comment 2 Andreas Bierfert 2007-11-07 23:13:41 UTC
same here for aterm/rxvt/urxvt

Comment 3 Andreas Bierfert 2007-11-07 23:21:16 UTC
Actually there is also a new version. At the links below you can find an updated
spec file with the permissions of the directory set to 755. It seems to work
without any rebuilds for packages depending on it.w

http://fedora.lowlatency.de/review/libutempter-1.1.5-1.fc7.src.rpm
http://fedora.lowlatency.de/review/libutempter.spec

Comment 4 Lukáš Tinkl 2008-01-02 14:36:23 UTC
Escalate as other bugs depend on this being fixed

Comment 5 Fedora Update System 2008-01-07 01:12:52 UTC
libutempter-1.1.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libutempter'

Comment 6 Fedora Update System 2008-01-11 22:02:46 UTC
libutempter-1.1.5-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libutempter'

Comment 7 Fedora Update System 2008-01-11 22:19:08 UTC
libutempter-1.1.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Dmitry V. Levin 2008-01-11 22:36:48 UTC
(In reply to comment #0)
> Description of problem:
> Since FC6 the utemper binary is hidden in /usr/libexec/utempter and applications
> using libutempter are required to have setgid utempter. This is causing problems
> as the applications have removed some environment variables like LD_LIBRARY_PATH
> and TMPDIR (see bug #229360).
> 
> Please move the utempter binary back to /usr/sbin and drop utempter group, or
> change permissions of the directory to 755.

I hope you understand that if you make the utempter binary world executable,
then you deliberately weaken libutempter security model.

LD_LIBRARY_PATH removal should not be a problem for executables like xterm.
TMPDIR removal is worse, thanks to dynamic linker which purges environment for
setGid executables too aggressively.


Comment 9 Fedora Update System 2008-01-15 22:57:26 UTC
libutempter-1.1.5-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.