Bug 31573 - installer crashed doing swapon,reinstall attempt produced new error
installer crashed doing swapon,reinstall attempt produced new error
Status: CLOSED DUPLICATE of bug 17791
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-03-12 17:13 EST by mjlindly
Modified: 2007-03-26 23:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-02 12:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mjlindly 2001-03-12 17:13:53 EST
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1470, in 
  File "fstab.py", line 408, in turnOnSwap
    isys.swapon (file)
  File "isys.py", line 142, in swapon
    return _isys.swapon (path)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
path: /tmp/swap/hda4

ToDo object:
after choosing the type of installation (workstation,server,custom) I now 
get the following error message: An error occured reading the partition 
table for the block device hda. The error was: No such file or directory. 
2 choices Retry or Skip Disk. Retry produced: The error was:Success, Skip 
disk produced: no valid devices were found in which to create new 
filesystems. Please check your hardware for the cause of this problem.
I'm a beginner at this, so it would be helpful if you could let me know 
what to do (in english). I have an HP Pavilion xl776, with an AMD Athlon 
850MHz processor w/3DNow. The hard drive is 60G. OS is Windows98 2E (this 
is why I need Linux).
Comment 1 Michael Fulbright 2001-03-21 15:24:58 EST
If you choose manual partitioning with disk druid, what are the 3 numbers next
to the /dev/hda summary at the bottom.

Should be something like (numbers will be different):

hda   [1216/255/63]   9538M   0M   9538M  <bar of color> 100%
Comment 2 mjlindly 2001-03-22 00:21:22 EST
I never get to the point where I can choose manual partitioning. During expert 
install, as soon as I hit next for the type of installation(workstation, server 
or custom) I get the error reading partition table message.
Comment 3 Michael Fulbright 2001-04-02 12:05:37 EDT
Assigning to an engineer.
Comment 4 Brent Fox 2001-04-02 15:30:19 EDT

*** This bug has been marked as a duplicate of 17791 ***

Note You need to log in before you can comment on or make changes to this bug.