Bug 316101 - bluetooth-applet not started by default
bluetooth-applet not started by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez-gnome (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 320091 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-02 16:46 EDT by Will Woods
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.14-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 06:30:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2007-10-02 16:46:34 EDT
With bluez-gnome-0.14-5.fc8, bluetooth-applet is not started at login. The desktop file in /etc/xdg/gnome/autostart does not show up in the session list like the items in /etc/xdg/autostart. Copying bluetooth-applet.desktop to /etc/xdg/autostart seems to make it start up as expected.
Comment 1 Will Woods 2007-10-02 16:55:12 EDT
As it stands, the Bluetooth Preferences is supposed to determine the behavior of
the applet (Always/Never show etc), but since the applet is never started, this
doesn't work at all. So we should be starting it by default.

I realize that starting the applet on systems where there's no bluetooth
hardware is sub-optimal. Someday we should have a smart way of determining when
to load the applet, but until then it's easy enough to disable from the Sessions
menu.

Comment 2 Bastien Nocera 2007-10-02 17:19:58 EDT
No, the point is that I moved the desktop file so it's only auto-started under
GNOME, as KDE has their own Bluetooth applet-y kind of thing, and I was told by
upstream that it should only be started under GNOME (see bug #258721)

Moving to gnome-session, as
%{_sysconfdir}/xdg/gnome/autostart/bluetooth-applet.desktop should get started
automatically.
Comment 3 Ray Strode [halfline] 2007-10-02 20:59:44 EDT
why should /etc/xdg/gnome/autostart do that?  Was this decided somewhere?

Right now, we already have /usr/share/gnome/autostart and /etc/xdg/autostart . 
If you use the former, or put OnlyShowIn=GNOME; and use the latter, do you get
the behavior you want?
Comment 4 Bastien Nocera 2007-10-03 06:12:31 EDT
See gsm_autostart_read_desktop_files() in gsm-autostart.c

But I didn't see system_dirs getting reassigned the retval of
g_get_system_data_dirs() (great variable name :( )

I'll move it to /usr/share/gnome/autostart
Comment 5 Bastien Nocera 2007-10-05 09:35:55 EDT
*** Bug 320091 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.