Bug 31718 - top/ps show deprecated 'shared' field on 2.4.x
Summary: top/ps show deprecated 'shared' field on 2.4.x
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 31719 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-13 21:54 UTC by Ed McKenzie
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-01 15:10:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2001-03-13 21:54:36 UTC
Kernel 2.4 seems to have deprecated the 'shared' statistic, and top/ps now 
show zero for this value. IMHO, it would be best if they didn't show a 
statistic that isn't being computed.

Comment 1 Jeremy Katz 2001-03-14 02:46:47 UTC
*** Bug 31719 has been marked as a duplicate of this bug. ***

Comment 2 Preston Brown 2001-03-14 20:38:29 UTC
we will keep displaying shared because many scripts are parsing the output of 
/proc/meminfo or "free".  Removing the statistic would break this.

At least, that's what Michael K Johnson, procps maintainer, told me.


Comment 3 Ed McKenzie 2001-09-01 15:11:36 UTC
Shared mem is computed again as of linux-2.4.6.


Note You need to log in before you can comment on or make changes to this bug.