Bug 317641 - xorg-x11 fonts with bad licenses need to be fixed or removed
xorg-x11 fonts with bad licenses need to be fixed or removed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On: 427845
Blocks: FE-Legal 226639 F9Blocker
  Show dependency treegraph
 
Reported: 2007-10-03 19:53 EDT by Jens Petersen
Modified: 2008-01-15 14:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 14:36:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-10-03 19:53:30 EDT
Description of problem:
Unfortunately the Luxi TrueType fonts in xorg-x11-fonts-truetype
are not under a completely free license since they can't be modified
and redistributed.

See
http://fedoraproject.org/wiki/Licensing#head-d8cc605dd386091c8b6be97b8a43fb6a5d624ae1-4

The license is not included in the package but from the source:

"The Font Software may not be modified, altered, or added to, and in 
particular the designs of glyphs or characters in the Fonts may not 
be modified nor may additional glyphs or characters be added to the 
Fonts. This License becomes null and void when the Fonts or Font 
Software have been modified."

Unless we can get the fonts released under a free license
(maybe unlikely after all this time?) I am afraid it needs to be
removed from Fedora.
Comment 1 Matěj Cepl 2007-10-04 04:48:38 EDT
Because I cannot 

During looking through this font, I found helpful email on one of Debian lists
(http://lists.debian.org/debian-devel/2005/03/msg00396.html) with a long list of
non-free fonts in Debian. And BTW, in Debian, luxi font always was in
ttf-xfree86-nonfree package.

I will probably go and make that long time overdue Merge Review of
xorg-x11-fonts (bug 317641) -- as a former Czech IP lawyer I am probably one of
few people in Red Hat who has stomach strong enough to plough through all these
licences. :-)
Comment 2 Jens Petersen 2007-10-07 21:04:41 EDT
(In reply to comment #1)
> Because I cannot 

sorry? :)

> BTW, in Debian, luxi font always was in ttf-xfree86-nonfree package.

Ok

> I will probably go and make that long time overdue Merge Review of
> xorg-x11-fonts

Yes please, that would be most helpful.
Comment 3 Jens Petersen 2007-11-04 18:27:12 EST
This was filed a bit late in the cycle and didn't make F8,
but since this is a legal issue and we say Fedora is pure FOSS
this really needs to be fixed for F9 IMHO: raising to F9Blocker list.
Comment 4 Tom "spot" Callaway 2007-11-26 11:12:53 EST
Emailed copyright holders to see if there is any chance of correcting the
licensing before pulling it out.
Comment 5 Tom "spot" Callaway 2007-11-28 09:58:58 EST
Upstream responded that they have no intention of changing the license. We need
to go ahead and remove the Luxi fonts.
Comment 6 Tom "spot" Callaway 2007-12-18 17:51:28 EST
The Luxi fonts are removed from xorg-x11-fonts in rawhide (7.2-5).

While I was in there, I audited the licenses for the rest of the fonts, and
caught a few more that probably should not be there:

- ibm-type1 (Courier) does not have permission to modify. Working with Josh
Boyer to try to get IBM to fix the license, otherwise, I'll pull that font
before F-9.
- misc-meltho (Meltho Syrian) has the same problem as the Luxi fonts, contacted
the copyright holder to try to get a license change, otherwise, I'll have to
pull it before F-9.

I'm just going to use this issue to track fonts that may need to be removed.
Comment 7 Mamoru TASAKA 2007-12-18 22:43:10 EST
Hi!

I tried to "locate luxi" and this seems to also affect

/usr/lib/python2.5/site-packages/reportlab/fonts/luxiserif.ttf
/usr/lib/python2.5/site-packages/reportlab/fonts/luxiserif_license.txt

in python-reportlab-2.1-1.fc8 (license text seems the same) ?
Comment 8 Tom "spot" Callaway 2008-01-07 15:06:11 EST
Created bug 427845 against python-reportlab. Good catch!
Comment 9 Tom "spot" Callaway 2008-01-14 12:49:57 EST
IBM refused to make license changes for ibm-type1, so that is being removed.

I received no response from upstream for misc-meltho, so that is also being removed.
Comment 10 Tom "spot" Callaway 2008-01-15 14:36:48 EST
All of the remaining fonts in the xorg-x11-fonts SRPM are ok for Fedora. Closing
out this bug.

Note You need to log in before you can comment on or make changes to this bug.