This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 317921 - 2.6.90-16,17 causes gdm to hang
2.6.90-16,17 causes gdm to hang
Status: CLOSED DUPLICATE of bug 321761
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-04 04:27 EDT by Mamoru TASAKA
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 08:26:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb log of gdmgreeter, scim-launcher (10.87 KB, application/x-gzip)
2007-10-05 10:40 EDT, Mamoru TASAKA
no flags Details
gdb log again (50.34 KB, text/plain)
2007-10-06 01:48 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2007-10-04 04:27:39 EDT
Description of problem:
With 2.6.90-{16,17}, gdm seems to hang.
Once a cursor appears, it never proceeds.

I privately mailed to Jakub about this issue, however
anyway I file a bug report so that this bug can be
tracked.

Version-Release number of selected component (if applicable):
glibc-2.6.90-15 (i686)
gdm-2.20.0-13.fc8
scim-1.4.7-5.fc8

I don't know if this is Japanese environ specific, however
I also write scim version.

How reproducible:
100%

Steps to Reproduce:
1. init 3
2. install glibc 2.6.90-{16,17}
3. init 5
  
Actual results:
gdm hangs

Additional info:
Reverting to -15 is okay.
Comment 1 Mamoru TASAKA 2007-10-04 04:49:43 EDT
(In reply to comment #0)
> Version-Release number of selected component (if applicable):
> glibc-2.6.90-15 (i686)
> gdm-2.20.0-13.fc8
> scim-1.4.7-5.fc8

This is of course glibc-2.6.90-{16,17} (i686)
Comment 2 Jakub Jelinek 2007-10-04 08:40:38 EDT
I can't reproduce it here, no scim though.
What exactly means gdm hang, does it allow you to pick users, enter password
and then you don't get a desktop, or does it get stuck earlier?
Comment 3 Mamoru TASAKA 2007-10-04 09:01:35 EDT
(In reply to comment #2)
> What exactly means gdm hang, does it allow you to pick users, enter password
> and then you don't get a desktop

No, after all rc sysinit daemons launch, black X screen appears,
a mouse pointer appears, then it never proceeds.
So no password dialog appears.

For scim: I uses ja_JP and
[tasaka1@localhost ~]$ rpm -qa | grep scim | sort
scim-1.4.7-5.fc8
scim-anthy-1.2.4-2.fc8
scim-bridge-0.4.13-4.fc8
scim-bridge-gtk-0.4.13-4.fc8
scim-debuginfo-1.4.7-5.fc8
scim-devel-1.4.7-5.fc8
scim-gtk-1.4.7-5.fc8
scim-libs-1.4.7-5.fc8
scim-python-0.1.3-1.fc8
scim-rawcode-1.4.7-5.fc8
scim-tomoe-0.6.0-2.fc8

If this can help.
Comment 4 Mamoru TASAKA 2007-10-05 10:40:37 EDT
Created attachment 217571 [details]
gdb log of gdmgreeter, scim-launcher

attached gdb log of gdmgreeter, scim-laucher, and attached strace result log
with gzipped.
Comment 5 Mamoru TASAKA 2007-10-06 01:46:03 EDT
Well, when I remove scim-python-0.1.3-1.fc8.i386, gdm does not
hang and I can log in to GNOME normally.
Comment 6 Mamoru TASAKA 2007-10-06 01:48:24 EDT
Created attachment 218281 [details]
gdb log again

Again gdb log. this time
glibc-debuginfo(-common), gdm-debuginfo, scim-debuginfo
python-debuginfo and scim-python-debuginfo (and others) are
installed.
Comment 7 sangu 2007-10-09 22:24:27 EDT
See Also bug 321761
Comment 8 Jens Petersen 2007-10-10 04:16:46 EDT
Based the gdb backtrace and bug 321761 I don't think this is related to scim
and should be reproducible without it.
Comment 9 Mamoru TASAKA 2007-10-10 08:26:29 EDT
Now marking this bug as a dup of bug 321761 (now this issue is
discussed on that bug)

*** This bug has been marked as a duplicate of 321761 ***

Note You need to log in before you can comment on or make changes to this bug.