Bug 31842 - if u secure keyboard on to a editor window and then lock your screen, then u cannot enter your password in the login window to unlock your session
Summary: if u secure keyboard on to a editor window and then lock your screen, then u ...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 6.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Mason
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 31841 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-15 10:53 UTC by K.Pavan Kumar
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 20:31:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description K.Pavan Kumar 2001-03-15 10:53:05 UTC
hi,

maybe this bug is not so important. It occurred in vain. I am using an 
Intel P-III processor with 128MB ram. I am using Redhat linux 6.22

the bug is as follows. I am an embedded systems programmer. While testing 
my bluetooth protocol stack, i usually tend to lock my session and go for 
a break. I came across the "secure keyboard" feature - by clicking the 
right mouse button on the terminal window in the X session. That way i 
secured the keyboard to one of the the terminal window. Then i locked my 
workstation.. i had also enabled the screen saver. after locking..i saw a 
2 line message on the screen ..it appeared..something like...xscrnserver - 
couldnot grab the keyboad : already grabbed...

and then later when i tried to unlock the session ... the login window 
didnot let me enter the password or type any character.

the only thing i could do was to restart my system.

I apologize if this bug has already been reported or fixed.

thanks and regards

K.Pavan Kumar

Comment 1 Trond Eivind Glomsrxd 2001-03-15 20:31:47 UTC
Emacs is not the component grabbing the keyboard - the terminal is. It also did
just what you told it to... if you want to shoot yourself in the foot, you're
allowed to.

Comment 2 K.Pavan Kumar 2001-03-16 05:26:27 UTC
*** Bug 31841 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.