Bug 318531 - `getent group` fails when member of an Active Directory domain
`getent group` fails when member of an Active Directory domain
Status: CLOSED DUPLICATE of bug 525576
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nss_ldap (Show other bugs)
4.0
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 11:32 EDT by Scott Merrill
Modified: 2009-09-30 16:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-29 13:53:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Merrill 2007-10-04 11:32:24 EDT
Description of problem:
RHEL4 AS server joined to a Windows 2003 Active Directory domain.
(Followed these instructions:
http://blog.scottlowe.org/2007/01/15/linux-ad-integration-version-4/ )

`getent passwd` correctly enumerates the local and AD users.
`getent group` fails with the following message:

getent: ../../../libraries/liblber/sockbuf.c:91: ber_sockbuf_ctrl: Assertion `(
(sb)->sb_opts.lbo_valid == 0x3 )' failed.
Aborted

Local groups defined in /etc/groups are returned, but no AD groups are returned.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux AS release 4 (Nahant Update 5)

How reproducible:
`getent group` on a RHEL4 AS server that is a member of an AD domain.

Actual results:
getent: ../../../libraries/liblber/sockbuf.c:91: ber_sockbuf_ctrl: Assertion `(
(sb)->sb_opts.lbo_valid == 0x3 )' failed.
Aborted

Expected results:
List of AD-defined groups.

Additional info:
Does not occur on RHEL5 (Red Hat Enterprise Linux Server release 5 (Tikanga)).
Comment 3 Bryan Mason 2009-09-29 13:53:05 EDT
Analysis of this issue has shown that this appears to be the same problem as described in Bug 525567.  In addition, tests have shown that this issue is resolved with a test version of nss_ldap that is linked against a version of openldap that has the fix for Bug 474788 and Bug 509507 (which are identical except one was fixed in 4.8.z with the release of openldap-2.2.13-12.el4_8.2 and the other is being investigated for release in RHEL 5.5).

Bug 525567 is a request to rebuild nss_ldap against the latest version of openldap, so I am closing this Bug as a duplicate of that one.

*** This bug has been marked as a duplicate of bug 525567 ***
Comment 4 Adam Williamson 2009-09-30 16:10:33 EDT
I believe you made a mistake in the number of the duplicate in comment #3, Bryan. It should be 525576. Adjusting.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 525576 ***
Comment 5 Bryan Mason 2009-09-30 16:31:06 EDT
Oops.  I did.  Thanks Adam!

Note You need to log in before you can comment on or make changes to this bug.