This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 319051 - NetworkManager: Failed to register GObject with DBusConnection
NetworkManager: Failed to register GObject with DBusConnection
Status: CLOSED DUPLICATE of bug 339011
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-04 14:59 EDT by Warren Togami
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 20:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-10-04 14:59:32 EDT
kernel-2.6.23-0.218.rc9.git1.fc8
wpa_supplicant-0.5.7-9.fc8
NetworkManager-0.7.0-0.3.svn2914.fc8
dbus-1.1.2-6.fc8
hal-0.5.10-0.git20070925.fc8

Occasionally NetworkManager gets into some state where it fails to startup again
unless service messagebus is restarted. 

[root@newcaprica ~]# NetworkManager --no-daemon
NetworkManager: <info>  starting...
NetworkManager: <info>  eth0: Device is fully-supported using driver 'e1000'.
NetworkManager: <info>  Now managing wired Ethernet (802.3) device 'eth0'.
NetworkManager: <info>  Bringing down device eth0
NetworkManager: <info>  Bringing up device eth0
NetworkManager: <info>  Deactivating device eth0.
NetworkManager: <info>  wlan0: Device is fully-supported using driver 'iwl3945'.
NetworkManager: <info>  Now managing wireless (802.11) device 'wlan0'.
NetworkManager: <info>  Bringing down device wlan0
NetworkManager: <info>  Bringing up device wlan0
NetworkManager: <info>  Deactivating device wlan0.
NetworkManager: <info>  (eth0) supplicant interface is now in state 2 (from 1).
NetworkManager: <info>  (wlan0) supplicant interface is now in state 2 (from 1).
NetworkManager: <info>  User request for activation of wlan0.
NetworkManager: <info>  Activating device wlan0
NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare)
scheduled...
NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure)
scheduled...
NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure)
starting...
NetworkManager: <info>  Activation (wlan0/wireless): access point 'Auto
rh-wireless' has security, but secrets are required.
NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
NetworkManager: <info>  wlan0: Device is fully-supported using driver 'iwl3945'.
A handler is already registered for the path starting with path[0] = "org"
NetworkManager: Failed to register GObject with DBusConnection

** (process:8058): WARNING (recursed) **: <WARN>  nm_signal_handler(): Caught
signal 6.  Generating backtrace...

aborting...
Comment 1 Warren Togami 2007-10-04 15:05:25 EDT
Arch: x86_64
Comment 2 Dan Williams 2007-10-31 20:40:35 EDT
Is this possibly after a suspend or resume?  Can you test with latest bits and
see if you get it?

*** This bug has been marked as a duplicate of 339011 ***

Note You need to log in before you can comment on or make changes to this bug.