This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 339011 - NetworkManager: Failed to register GObject with DBusConnection
NetworkManager: Failed to register GObject with DBusConnection
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
bzcl34nup
:
: 319051 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 20:45 EDT by Bill Nottingham
Modified: 2014-03-16 23:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 10:39:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error log of crash (7.01 KB, text/plain)
2008-05-14 10:26 EDT, Robin Norwood
no flags Details

  None (edit)
Description Bill Nottingham 2007-10-18 20:45:33 EDT
Description of problem:

All of a sudden, NM fell over. That message was in the logs. Now, NM
just dies with the same message every time I try to start it.

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-0.3.svn2983.fc8
Comment 1 Warren Togami 2007-10-19 00:11:39 EDT
I occasionally see this too.  When this happens, restarting messagebus and
haldaemon before NetworkManager doesn't seem to allow it to recover.  I need to
reboot for it to work again.

x86_64 iwl3945
Comment 2 Dan Williams 2007-10-19 00:57:11 EDT
will put some debugging info into the next build to try to narrow this down
Comment 3 Dan Williams 2007-10-31 18:33:59 EDT
If you get this again, please update.  The debugging info is there.
Comment 4 Dan Williams 2007-10-31 20:40:36 EDT
*** Bug 319051 has been marked as a duplicate of this bug. ***
Comment 5 Ben 2007-12-06 21:26:27 EST
I can almost guarantee that this is related to the execrable gconf, as rebooting
did NOT fix anything for me, but deleting ~/.gconf/system/networking and
rebooting DID.
Comment 6 Bug Zapper 2008-04-04 10:09:57 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Robin Norwood 2008-05-14 10:25:02 EDT
I'm seeing a similar, but less severe issue in rawhide.

o NetworkManager is running, connected to my home wireless Network.
o I hibernate the system. (Staying logged in)
o I come into the office the next morning, plug in the wired network cable, and
power on the system.
o When the system is done booting, I enter my screensaver password, and
everything seems to be fine, except there's no NM icon.

doing a 'service restart NetworkManager' as root fixes the problem.

I'll attach NetworkManager's droppings in /var/log/messages from when I went
into hibernate mode until after resuming.  The error is the same as the one in
the summary of this bug.

$ rpm -q NetworkManager dbus
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386
dbus-1.2.1-1.fc9.i386
Comment 8 Robin Norwood 2008-05-14 10:26:57 EDT
Created attachment 305366 [details]
Error log of crash
Comment 9 Dan Williams 2008-05-14 10:39:36 EDT
Robin; this should be fixed in latest rawhide/koji bits, please try svn3669 or
later:

http://koji.fedoraproject.org/koji/taskinfo?taskID=608605 (f8)
http://koji.fedoraproject.org/koji/taskinfo?taskID=608593 (f9)
http://koji.fedoraproject.org/koji/taskinfo?taskID=608599 (f10)

can you test those?  Also, were you connected with VPN at the time of the hibernate?
Comment 10 Robin Norwood 2008-05-14 22:54:43 EDT
Yes, I was connected to the VPN when I hibernated (almost certainly).  I've just
installed the above version, and I'll let you know how it works out in the morning.
Comment 11 Dan Williams 2008-05-15 10:26:14 EDT
That updated version specifically fixes a refcounting issue that triggered the
dbus-glib assertion after resuming from hibernate when the VPN was active before
going to sleep, and I'm pretty sure your issue is the same.  Let me know!
Comment 12 Robin Norwood 2008-05-15 13:17:17 EDT
Yes, NetworkManager seems to survive hibernation now.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.