Bug 31921 - Exploring and fixing /etc/modules.conf
Exploring and fixing /etc/modules.conf
Status: CLOSED DUPLICATE of bug 26860
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-15 19:28 EST by wjwarner
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 19:28:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wjwarner 2001-03-15 19:28:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.25wjw i586)


I have Wolverine, up2date asof today with latest kernel ...25 recompiled so
my ps/2 mouse works.  Based on error lines in /var/log/messages I hand
tweaked /etc.modules.conf to get sound and printing to work    


Reproducible: Didn't try

Despite the tedium I could re-install from my Wolverine CD and re-apply
all  up2date rpms if  really needed -- I hesitate to badger but I think you 
otter go for a third order of mustelidae<grin>

sndconfig fails with errors as follows
----------------------------
 modprobe error
 The following error occurred running the modprobe program:
 /lib/modules/2.4.2-0.1.25/kernel/drivers/sound/opl3.o:
 init_module: No such device
 /lib/modules/2.4.2-0.1.25/kernel/drivers/sound/opl3.o: insmod
 /lib/modules/2.4.2-0.1.25/kernel/drivers/sound/opl3.o failed
 /lib/modules/2.4.2-0.1.25/kernel/drivers/sound/opl3.o: insmod
 synth0 failed
---------------------------------
I have an ESS1868 sound card which actually works with
hand tweaked /etc/modules.conf as follows
-----------------------------------
alias eth0 3c59x
alias parport_lowlevel parport_pc
options parport_pc io=0x378 irq=7 dma=none
alias char-major-180 lp
alias sound-slot-0 sb
options sb io=0x220 irq=5 dma=1 mpu_io=0x330
options sound dmabuf=1
alias sound-slot-1 opl3
options opl3 io=0x388
alias sound-service-1-0 uart401
---------------------------------------
I hacked the above together by guessing which modules went
with things like "sound-slot-1" by noticing what caused 
error lines like this in ..../messages:
------------------------------------
Mar 15 18:35:16 user1-hos modprobe: modprobe: Can't locate module synth0
-----------------------------
by the way sndconfig triggers the above line 
 
the sb module for the soundcard reports in ../messages as follows during
boot:
-------------------------------------------
Mar 15 17:29:53 user1-hos kernel: Soundblaster audio driver Copyright (C)
by Hannu Savolainen 1993-1996
Mar 15 17:29:53 user1-hos kernel: sb: ESS ES1868 Plug and Play AudioDrive
detected
Mar 15 17:29:53 user1-hos kernel: sb: ISAPnP reports 'ESS ES1868 Plug and
Play AudioDrive' at i/o 0x220, irq 5, dma 1, 3
Mar 15 17:29:53 user1-hos kernel: SB 3.01 detected OK (220)
Mar 15 17:29:53 user1-hos kernel: ESS chip ES1868 detected
Mar 15 17:29:53 user1-hos kernel: <ESS ES1868 AudioDrive (rev 11) (3.01)>
at 0x220 irq 5 dma 1,3
Mar 15 17:29:53 user1-hos kernel: sb: ESS ES1868 Plug and Play AudioDrive
detected
Mar 15 17:29:53 user1-hos kernel: sb: Failed to initialize ESS ES1868 Plug
and Play AudioDrive
Mar 15 17:29:53 user1-hos kernel: sb: 1 Soundblaster PnP card(s) found.
---------------------------------------------
note the claimed use of dma 1 and 3, although only dma=1 was in the sb
options
This use of dma 3 conflicted with the parport which also claimed dma 3 as 
installed --hence the parport option dma=none added per above
Comment 1 Bill Nottingham 2001-03-15 20:03:29 EST

*** This bug has been marked as a duplicate of 26860 ***

Note You need to log in before you can comment on or make changes to this bug.