Bug 319421 - livecd-iso-to-usb fails with f8test3
livecd-iso-to-usb fails with f8test3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
: 319861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 19:39 EDT by Max Spevack
Modified: 2013-01-09 23:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 20:19:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2007-10-04 19:39:52 EDT
Description of problem:

livecd-iso-to-usb fails on test3.  It worked (same hardware) with a custom-built
rawhide 2 days ago.  Therefore, I assume it is the Test3 ISO that is in some way
messed up, as opposed to livecd-tools

Question 1: why is it broken now, and can we fix it?

Question 2: is this a test case that is in our general ISO smoke test/list of
stuff that has to work before a release?  If not, it should be.

root@localhost ~ % df
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                       35G   12G   22G  35% /
/dev/sda1              99M   19M   76M  20% /boot
tmpfs                 501M     0  501M   0% /dev/shm
/dev/sdb1             983M  4.0K  983M   1% /media/usb

root@localhost ~ % livecd-iso-to-disk
~spevack/Fedora-8-Test-3-Live-i686/Fedora-7.92-Live-i686.iso /dev/sdb1
Copying live image to USB stick
cp: cannot stat `/media/cdtmp.nG3231/squashfs.img': No such file or directory
Cleaning up to exit...

Version-Release number of selected component (if applicable):
Comment 1 Max Spevack 2007-10-04 19:41:03 EDT
the sha1sum of my download matched, etc.  pretty sure i checked all obvious
PEBKAC stuff.
Comment 2 Jeremy Katz 2007-10-04 19:52:19 EDT
What version of livecd-tools do you have installed?
Comment 3 Max Spevack 2007-10-04 20:01:11 EDT
livecd-tools-009-1.fc7

I downloaded Test3 on my F7 box and ran livecd-iso-to-disk.
Comment 4 Jeremy Katz 2007-10-04 20:19:17 EDT
That's why -- right now, you have to use rawhide livecd-tools to write the
rawhide  obvious and better for future changes.  A new livecd-tools will be
pushed to f7-updates before F8 comes out, but holding off on that until things
are stable.
Comment 5 David Zeuthen 2007-10-04 20:30:40 EDT
Since it's just a shell script how about including it on the root of the iso9660
file system too?
Comment 6 Jeremy Katz 2007-10-05 10:00:51 EDT
*** Bug 319861 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.